cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS M50 Mark II started malfunctioning after firmware update

DefaultNano
Apprentice

Hey, I recently updated from 1.0.1 to 1.0.3 and this has caused quite a few issues on my M50 camera. Sometimes, the camera will ignore the on/off position and turn on the green led light, as well as the screen backlight, but then not do anything else. The only way to solve this is to unplug and replug the camera, and even then it's not guaranteed to fix it.

 

It also often returns error code 70 (fixed on turning off and on the camera). This occurs with multiple different lenses and batteries, so I've narrowed it down to likely the camera's firmware. What's the best way to go about downgrading it? I haven't been able to downgrade as it says "Failed to transfer the firmware" in EOS utility.

2 REPLIES 2

rs-eos
Elite
Elite

Firmware cannot typically be downgraded, so I don't think that will be an option.  It would be best to contact Canon and see about having it repaired.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

krahe
Rising Star
Rising Star

It sounds like a faulty on/off switch. After what was likely several thousand on/off cycles (my photo counter is nearing 9,000), my on/off switch started to fell mushy rather than crisp as it always had before, and now I'm having symptoms similar to yours. I plan to send mine in for repair shortly.

Kevin Rahe
EOS M50 Mark II
National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements