cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS 5D Mark III Producing Corrupted Images

Cailinnua
Apprentice

I have a Canon 5D Mark iii camera which keeps producing corrupted images as attachedUntitled.png. There is no pattern to these images being produced, I am using the same lens and settings and might take 200 images with 3 corrupt and 30 with 10 corrupt. I have attached a sample of images being produced. Sometimes they have these colour blocks, sometimes less or more of the photo is covered, and sometimes black 

10 REPLIES 10

Tronhard
Elite
Elite

Hi Calin and welcome to the forum:

Just before this began to happen, has anything changed?  For example any settings, different cards etc.

The first things I would suggest are the least invasive:
1.  Do full camera reset to default settings:  If you want to save your current configuration, save it to one of the C1-C2 custom settings.

2. Try different cards.  You may have a corrupt card


cheers, TREVOR

"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

Hi Thank you for your reply, I have tried a number of different cards, I haven't reset will try that now

 

Do you see the corrupt images in live view why using the rear LCD Screen. If so your image sensor maybe is on its way out.

-Demetrius

40D, 5D IV, EF 16-35mm F/2.8L III, EF 24-70mm F/2.8L II, EF 28-135mm F/3.5-5.6 IS USM, EF 50 F/1.8 STM

430EX III-RT & 600EX II-RT


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

If this is the issue can the image sensor be replaced?

Did you do a reset on the camera yet?  It may solve your issue for no cost.


cheers, TREVOR

"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

I was under the impression that OP had reset the camera to factory . Since they mentioned the use of other memory cards.

-Demetrius

40D, 5D IV, EF 16-35mm F/2.8L III, EF 24-70mm F/2.8L II, EF 28-135mm F/3.5-5.6 IS USM, EF 50 F/1.8 STM

430EX III-RT & 600EX II-RT


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

I did ask and they have not confirmed that and they responded that it was something they would try when I suggested this. "Hi Thank you for your reply, I have tried a number of different cards, I haven't reset will try that now"


cheers, TREVOR

"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris

I'm trying to figure out how to reset the camera sorry for delay 

Have you downloaded a copy of the manual for this camera?  I strongly recommend that as it is the first port of call for any issues.  You can find it HERE - look on P56.


cheers, TREVOR

"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris
Avatar
click here to view the press release
Announcements