Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon T3i USB device not recognized (win 81 64 bit)


Subject says it all, pretty much.  When I got this laptop (windows 8.1 64 bit), the installed drivers worked fine for my T3i.  Now, all of a sudden, I'mn getting unrecognized device.  Nothing odd has happened except that I plugged the camera into a mac to download photos there, but that shouldn't have any effect on the device being recognized on Windows.  How do I fix this?


Try a different card or format the existing card in camera. I am pretty sure the problem relates to a files downloaded flag the Mac sets.
John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic


Update: this is pretty weird, I was all prepared (as John suggested) that the Mac connect had made the card unrecognizable.  Then, just on a hunch, I switched cables, and guess what, it worked.  The cord I'd been trying to connect with was one I grabbed from my pile of miscellaneous cables...right connectors, but who knows?  The one that lives in my camera bag and that I normally use, worked just fine.  Go figure!

This has come up several times before....


Now that just about every device that needs a power charge can be charged via a USB cable, there are now many USB "charging" cables on the market.   The pinouts for USB cables (there are various connectors) assign some pins to transfer power and some pins to transfer data.  On a "charging" cable, only the power pins are connected -- the data pins do not actually connect from end-to-end.


It sounds like you might have grabbed a "charging" cable instead of a regular USB cable where all the data pins actually work.


You may want to mark your cables so you know which ones actually work to transfer data (and btw, the camera doesn't use the power pins at all.  It only cares about the data signals.  So a charging cable is completely worthless to the camera.)


Tim Campbell
5D III, 5D IV, 60Da

Tim, I think I will label that one as an "I dunno what the heck" cable.  I've definitely gotten a data connection with some devices -- I did it with my GPS last week -- but not with the camera, so I guess it's got a highly eccentric pinout.  Anyway, gtk that it can be something as simple as the cable.