Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon T2i screen and shutter release won't work, but viewfinder and autofocus are fine.


The title sums up most of what I know. Regardless of the mode dial position, the screen stays totally dark, and I can't take photos. The viewfinder displays and autofocus seem to be working fine.


The camera is about five years old, maybe 25k shutter releases, and I'm still using the original (Canon) battery. When I put the battery in the charger, the light turns from yellow to green within minutes, then I put it back in the camera, and 99 times out of 100 it still doesnt work. If I immediately put it back in the charger, the light is yellow. I've tried checking the battery voltage, but I can't really tell if I'm touching the contacts or not, so I don't know.


I'm having a hard time searching for this specific set of symptoms, but I'm hoping it's a battery issue, so I bought a new one (online, waiting for it to ship). Can anyone confirm this, or provide any other insights? Thanks.



If "autofocus" is working, then the camera must have power.


Switch on the camera, then press the "Menu" button.  Does your LCD display now show the menu?


There are a handful of things the LCD can display when using the camera -- but one of the options is for the LCD to simply remain off.  If you press the "Disp" button, each time you press it the camera will advance to the next mode (if on the last mode and you press "Disp" again, it circles back to the first mode -- in other words it's just a loop of about 4 different options (that's from memory, I'm not checking a camera as I write this reply.)


It's possible you may have unintentionally put the LCD display into the mode where it is supposed to remain off.  Try pressing "Disp" to see if it switches on for you.



Tim Campbell
5D III, 5D IV, 60Da

No, the LCD does not display anything, no matter what buttons I press. The bigger problem is that the shutter release does not function.

If the "Menu" button can't wake the display and pressing the "Disp" button does nothing... and in light of the fact that pressing the shutter button also does nothing... it sounds like something has failed in your camera.


Though the battery is old (batteries usually need to be replaced after 3-5 years and batteries will still fail from just sitting unused for too long) I'm thinking the auto-focus probably would not work at all if it were a simple battery problem.


You should contact Canon service.  Your options are to send it for repair, or you might consider just replacing it.  If you do consider replacing it, Canon will offer you a discount on an upgrade via their Loyalty program (service can tell you about the program) so even if you opt to replace it, do not discard your T2i (assuming the camera is broken, it will still get you a discount on a newer model.)



Tim Campbell
5D III, 5D IV, 60Da

As of yesterday I am having the same issue as described by monguin61, even the age (5 years) is about the same.

Can confirm that it's not a battery problem (I tried with a different but certified battery, same issues).

When looking through the viewfinder I can see the settings when focusing. No buttons except autofocus and flash show any reactions

huh, the issue seemed to vanish. I switched between two batteries a few times and suddenly the functionality is back to normal.

The problem was intermittent at first for me as well - with some luck, I could switch the camera off and on several times, and eventually it would work. As of today the camera has not been working for about a week. I also tried a new Canon battery, to no effect. I will post any updates here.