Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 5dS - "Release Shutter without Lens" option???!?!?


Greetings - 

I have a Canon 5dS, and am trying to get it working with a M42 to EF adapter that includes the Focus confirm chip. The camera appears to be able to see the chip - it shows 50mm and f1.4 when I'm using it, as expected, but when I trigger the shutter, I get a 00 error, saying there's a problem communicating with the lens, clean the contacts, etc. My understanding is that I need to toggle the "Release Shutter without Lens" option in settings, but I've so far been unable to find it. I have other Canon cameras, notably an EOS M6, and found the option and have been successful using the adapter, and the adapter worked on my Canon 5dII just fine. Does the option exist on the 5dS? Am up to date on firmware, camera works fine with other lenses including Manual Focus Zeiss ZE's. 



While I have set "Release Shutter Without Lens" on my Canon mirrorless camera (M5), I have never done so on any of the various Canon DSLRs I've been using for nearly 20 years. And, yes, I have used several adapted lenses on them without any problem. I've used both "chipped" and plain adapters over the years.

This website is pretty old now, but has been a pretty good resource for adapted lenses. Maybe it will help you.

I am not sure why you are getting that error, but a few possibilities come to mind.

  • There is something wrong with that particular chip. It could be the programming or perhaps it's just not mounted correctly on the adapter, is misaligned with the connectors in the camera. You might compare it to the orientation of the contacts on the rear of an OEM lens, to see if you can spot any differences.
  • It is my understanding that some of those chips can be user programmed so that image EXIF will display something that can help identify the lens. You note that the camera "thinks" a 50mm f/1.4 is mounted. If the camera is also thinking it's an autofocus lens, too, it may be the cause of the error you're seeing. You might contact the manufacturer of the adapter to see if they can help. Or maybe they have info on their website.
  • The most useful thing the chipped adapters ever did for me was allow the camera's Focus Confirmation feature to work. But to do so the camera needed to be set up properly in advance and if I recall correctly I always had to mount an OEM autofocus lens to do the camera settings.... switching to One Shot mode (no Focus Confirmation in AI Servo mode), choosing Single Point or Spot (Precision) Single Point focus pattern, then selecting the AF point I want to use. None of this could be done when there was no lens on the camera or when the adapted lens was installed. It could only be done with an OEM autofocus lens mounted, which I then removed to install the adapted lens. Maybe one of these settings is incorrect and causing the error you're seeing. I don't recall ever having an error when I didn't have these set right, but I don't have a 5Ds so can't say maybe it's different.
  • You say you are getting a "00 error"... are you sure it's an error? Is it displayed on the rear LCD screen with "ERR"? Or is it just "00" displayed on the top monochrome screen? If it's the latter, that's telling you the camera can't find the lens aperture to control it... it's NOT an error code, per se. This suggests you might have the wrong exposure mode selected. Adapted lenses have no means of communicating with the aperture of the lens, so you can only use M exposure mode, will need to set the aperture manually on the lens itself, and then manually adjust both ISO and shutter speed with "match needle metering" method (where you adjust to center the meter scale indicator on zero, if relying upon the camera's built in metering system). With adapted lenses you CANNOT use Tv or P or Auto or any SCN modes (if the 5Ds even has them). You MIGHT be able to use M-with-Auto-ISO or Av auto exposure modes. In other words, you cannot use any auto exposure mode where the camera would need to adjust the lens aperture... but may be able to use auto exposure modes where it is adjusting the shutter speed or the ISO. 

I hope this helps, but have to admit I'm doing a lot of guessing!


Alan Myers
San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7DII (x2), 7D(x2), EOS M5, some other cameras, various lenses & accessories

I think its possible that the chip has incompatibilities with the 5dS - the one I'm trying currently (I have multiple, of them, actually) is, I believe, an older "v2" chip from Fotodiox - they're up to a v10, it looks like. Their documentation is... sketchy, to be honest. I do also have other adapters with and without chips, and get the same error. Since it was happening with multiple adapters, I was wondering about Camera settings. I will say that normal Canon EF lenses of various ages seem to work fine, so I believe the camera and contacts are all good. I'll see about going through some of the settings you suggested and see if any help. I have (mostly) been using "M" for the most control possible. 

Still would like to know from others who have 5Ds or from Canon (if they're listening) whether then "shutter release without lens" is an option and I just didn't find it, or if it isn't available on the 5Ds???

No Canon DSLR or SLR camera has ever had "Release Shutter Without Lens" custom function. This custom function is specific to EOS M and EOS R series cameras.


Current Gear: EOS 5D Mark IV, EF 16-35mm F/2.8L III USM, EF 24-70mm F/2.8L II USM, EF 50 F/1.8 STM, EF 85mm F/1.8 USM, EF 70-200mm F/2.8L IS III USM, 430EX III-RT, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D, Sigma 17-50mm F/2.8 EX DC OS HSM & EF 28-135mm F/3.5-5.6 IS USM


Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D


Canon DSLRs do not include a menu option to release the shutter without a lens attached.  Make sure you are using a shooting mode that does not require the camera to set the Av in the attached lens.  

The camera cannot automatically set an aperture value with a fully manual lens.  Use Av or M shooting modes.  If you are still getting the error, then your mount adapter is faulty.

"The right mouse button is your friend."


Your adapter isn’t faulty, it’s just not compatible with the 5Ds. I have experienced the same thing with older chipped adapters on my 5D Mk III. They work fine on older, simpler cameras, but cause errors on more complex cameras like the 5D Mk III or 5Ds.

If it were me, I would  remove the AF confirm chip, as I never found them very accurate. A non-chipped adapter will not give an error. If you are having problems with a non-chipped adapter, the mirror is probably hitting the back of the lens at certain focus distances.

If you really need AF confirm, I would get another adapter with a more modern, up to date chip, that is compatible. 


Mike Sowsun
click here to view the gallery