cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 5D Mk IV FTPS mode

albasdad
Contributor

Hello Everyone,

 

Has somebody managed to connect with Canon 5D Mk IV to FTPS server (Secure FTP)?

FTP (unsecure) is quite simple but I am unable to install FileZilla's SSL Certificate on my camera - of course if there is no certificate, there is no connection to FTPS. I have no problem connecting to my FTPS server from a number of FTP Clients, including from iPhone but my Canon 5D Mk IV just fails in this.

Canon Support replied that FTPS is not supported but I don't believe Canon would include this option in firmware and documented in Manual if it was not supposed to be supported.

 

Thanks for your help

 

best regards

 

Andre

13 REPLIES 13

Bob, Maybe I sound more stupid than I am...of course I try to load it from an active card 🙂

 

albasdad
Contributor

After a lot of trial and error I ahve finally solved this puzzle of getting 5D Mk IV communication with FTP server in secure (FTPS) mode.

Alas, the disappointment : over 200 Mbps WiFi, uploading from 5D Mk IV to FTPS is maxing at 2 Mbps 😞 So transferring 100 RAW shots would take 3.5 hours ! Not a very practical solution, unfortunately! 

Aha!  So what was the secret?  I've copied root.pem to the root of the SD card so it now says its found it, but there's an error loading it.

There is no secret. It is still not working because there is a Firmware bug and the camera does not accept standard certificates that are needed for FTPS. Canon says that it is not clear if it will be corrected.

Avatar
click here to view the gallery
Announcements