Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon 5D Mark IV hot shoe / transmitter issue


I have a Canon 5D Mark IV and mid shoot the camera stopped talking to the transmitter. Since then, I've tried everything. My hotshoe works - it triggers my 600EX II RT flash perfectly. Using a sync cord with my lights works just fine (I use both White Lightnings and Dynalites). All the remote triggers I have (cybersync, pocket wizard, and one other I can't remember) all work when I hit the test button, but none will fire when I hit the shutter release. And it's super strange it happened mid shoot-was working perfectly before that (and always has). I'd love to escape using my sync cord, but that's the only thing that is working right now. Any suggestions/ideas?



Perhaps something is interfering with the wireless signal from your hotshoe transmitter.   A lot of stuff operates in the 2.4 ghz range and a strong signal from another device will wipe out everything else.  Try holding your camera very close to one of the receiver equipped lights and see if it fires.


EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

Thanks, I tried that. Same problem 😞


National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th