Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can’t take photographs


Hello all!

Allow me to begin by saying that I don’t have a clue about what I’m doing, so please be gentle!

I bought a lovely 77d a couple of years ago. The guy in the shop kindly set everything to auto and I’ve had no trouble since. I got the camera with the kit lens and I bought an additional 70-300mm lens which I use more often. 

Yesterday, I was at a horse show, happily taking shots and then I took it back out of the bag and it just wouldn’t work. 

I changed the memory card, took the battery out and then back in and removed and reattached the lens, but all to no avail. 

If you could give me some guidance I would be very grateful. Thank you! 



I suspect this may be related to auto-focus (AF).


By default the camera will not take a photo unless it is able to confirm that it has focused (this behavior is known as "focus priority").  The behavior can be overriden (in a couple of ways).


In order to lock focus ... the camera will need enough light and a subject with some contrast.  


If you test the camera outside on a bright sunny day ... it may have no difficulty quickly locking focus.  Do the same thing in poor lighting (e.g. inside with poor lighting) and it may struggle to lock focus.  Sometimes you'll hear the focus motor trying to find focus ... and then it gives up.


There could be other reasons for it's failure to let you take a photo ... this is just one possible reason.


There is a switch on the side of the lens barrel labeled 'AF/MF' (auto-focus vs. manual focus) and if you switch it to manual then it should take a shot the moment you press the shutter button (it wont try to focus if using manual focus mode ... of course it also means you have to manual focus or you'll get blurry images).    If the focus mode is changed from the factory default mode of 'One Shot' to instead use 'AI Servo' mode then it will also immediately take photos (but it is highly recommended that when using AI Servo mode, you first half-press the shutter ... wait for the camera to focus ... then fully press the shutter when you are ready to capture the shot.  AI Servo will continuously keep focusing as long as you keep the shutter button half-pressed.


Note that if the camera is in full 'Auto' mode, many settings are locked out.  


The camera also has Program mode (P).  P is nearly identical to full Auto mode ... *except* you can change settings and override camera defaults.  


You'll benefit enormously from learning the ins and outs of your camera.  There are some books that are great for beginners.  Bryan Peterson's book 'Understanding Exposure' is very good for beginners.  Scott Kelby also has a 'Digital Photography' series of books.   These books are not Canon model-specific ... they're generic books that would apply to most any Digital SLR camera user.


Tim Campbell
5D III, 5D IV, 60Da

View solution in original post





Welcome to the site.


Is the camera coming on (display on near shutter release displaying information such as battery level icon) or is it completely dead?  Anything showing up on the rear display when you turn on the power switch?



EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video

Hi Rodger,
Thank you for replying.
Yes, the camera is turning on. It shows full battery, says A in the ISO box and 999 in brackets and WiFi off. That’s it.
Sorry, I probably should have put that in my post.


Does the camera seem to power-up as normal? Or do you just mean that the shutter won't release? Are the LCD displays working as they should? Does the 77d have any sort of a "lock" button that might be keeping the shutter from workig?


Are you using a full size SD card or a micro SD with a card adapter? Have you attached any third party accesories like a battery grip or flash or a non-Canon battery?


Edit- Rodger must have had more coffee this morning than I did...

Hi BurnUnit,

Yes, power seems normal and all displays look normal to my uneducated eye!
When I press button to take a shot, in any mode, nothing was happening.
But.... just to reply properly to you, I tried again and now it’s taking photos! Which is great! But, I didn’t change anything and it certainly wasn’t playing ball yesterday so any ideas as to what I might look for in the future would be great as I missed being able to photograph what I needed to yesterday ☹️

So... What kind of SD card are you using, and has it been properly formatted in the camera? Have you set the calendar and clock in the camera?

I actually don’t know the answer to this, so I am going to go and find out, thank you.

Oh and yes, there is a lock lever. But I tried that yesterday to no avail. Just tried it again now and it’s working no matter which way the lock lever is set!

Does it happen with both lenses? If you change the lens to manual focus?

As Kvbarkley noted, this could be because the lens isn't focusing possibly because the AF switch on the lens was accidentally bumped to manual or the switch needed to be exercised a few times to clean its contacts.


Depending upon your camera settings, the shutter won't operate until the camera confirms focus has been achieved.


If this problem happens again, manually throw the lens well out of focus using the focus ring on the lens and then press the shutter button half way to see if it is pulling it back into focus.





EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video