cancel
Showing results for 
Search instead for 
Did you mean: 

Camera won't take picture in Manual. Please help.

t2iChicago
New Contributor

Hello, thank you for helping.

 

Everytime I use manual mode my camera stops taking pictures properly. I hit the button to take a picture and it takes a few seconds to take the picture or it wont take it at all. This does not happen when I am using the LCD to take the picture. I have it in manual focus and if i put it in auto I use auto-servo. The lens is on tight.

3 REPLIES 3

Danny
Moderator
Moderator

Hi, t2iChicago!

So that the Community can help you better, we will need to know exactly which camera model you're using.  Your user name implies that it might be a Rebel T2i, but we don't want to jump to conclusions. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, our US-based technical support team is standing by, ready to help 24/7 via Email at http://bit.ly/EmailCanon or by phone at 1-800-OK-CANON (1-800-652-2666) weekdays between 8 AM and midnight ET (5 AM to 9 PM PT) and Saturdays from 10 AM to 8 PM ET (7 AM to 5 PM PT).

Thanks and have a great day!

hsbn
Reputable Contributor
Sound like Mirror Lock Up is turned on. Press the shutter once, the viewfinder goes black, press again it will take photo. You can reset your camera to factory default or just turn off Mirror Lock Up (check your manual).
--------------------------------------------------------------------------------------------------
Weekend Travelers Blog | Eastern Sierra Fall Color Guide

Debbie
Occasional Contributor

The mirror lock-up scenarion was the cause of this problem for me. I was so relieved!!