Showing results for 
Show  only  | Search instead for 
Did you mean: 

.CR3 on IPad?

Is it still the case that the Photos app on iPad Pro (latest iPadOS) can’t import CR3 files? I just tried this with a card reader and it said it was importing, but I got a white expanse. Reconfirmed that .CR2 imports just fine from the card reader. Thanks!


Tak! So the EOS R and the RP have different file formats?


There is a way, but it's not well suited for me. .CR3 is supported on iPad Pro. It’s an app issue. Apparently, one must use the Canon Camera Connect app to connect to the camera via WiFi. I tried it and it works. I uploaded .CR3’s with the Canon app, exported them to the Photos app, and from there I imported them into Lightroom for iPad, which was my objective in the first place. This is a needlessly complicated process. I don’t know who needs to fix this—Apple or Adobe—but it does need fixing, IMO. As things stand, this involved process isn’t of much help to me, as I would like to be shooting with another card while my pics upload to iPad Pro from the previous card. Uploading from the card works with .jpg and .CR2, but not with .CR3’s.


It would also be really neat if Camera Connect could upload from a variety of sources other than cameras. I'm thinking not only a card reader, but my My **bleep** wireless SSD drive.


Perhaps the import process will be streamlined when Photoshop for iPad Pro is released.

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th