cancel
Showing results for 
Search instead for 
Did you mean: 

80d - Mode dial not selecting correct mode

reynsteph
Apprentice

Hi all,

 

I am hoping somebody can help me with an issue I am having with a recently purchased new-to-me Canon 80d camera (purchased from B&H Photo).

 

When I turn the mode dial to select my desired mode, the display screen does not show what has been selected on the mode dial. Below is a list of what is selected on the mode dial and then the selection displayed.

 

B -> B

M -> B

Av -> Tv

Tv -> Tv

P -> P

A+ -> P

Flash Off -> P

CA-> P

SCN -> C1 p

Creative filters -> C2 p

C2 -> C2 p

C1 ->  C1 p

 

Has anybody else experienced this problem? Is there a setting that I have not implemented?

 

I have tried using a brand new SanDisk SD card and updating the firmware on the camera.

11 REPLIES 11

shadowsports
Elite

Greetings,

I recommend resetting the camera to defaults and retesting. 

 

If the behavior persists, contact B&H to set up a return. 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

Thank you for responding. I changed the settings to default and was still having the issue, so I am returning.

 

Thanks again.

"I recommend resetting the camera to defaults and retesting."

 

Hold on there fella!  How did you reset the defaults?  Menus, tools, clear all setting AND clear all custom settings.  <-- that is the important one, not the first one. WHat you are seeing looks more like a custom set up not factory default.

EB
EOS 1DX and 1D Mk IV and several lenses!

Nice Ernie!

Did not know there was a second reset for Custom Settings.  Helpful for sure. 

 

Custom Reset.png 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

reynsteph
Apprentice
Thanks ebiggs1! I tried clearing both of those settings but the problem persisted.

I think this is going to be a problem for Canon to solve and the only additional thing that you might try is to leave the battery out for several minutes, then turn the power switch on (with the battery still removed) and cycle the mode dial.  Then put the power switch back to off, insert the battery, and try again.

 

But it sounds like either the encoder switch of the mode dial is defective or the decoder IC that interfaces it to the main camera control system has become defective.  You stated the camera was "new to you", if this is a used camera within the B&H return period then I would return it.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video

ebiggs1
Legend

Cameras that do not have a separate keep alive battery, that you can remove, don't benefit form that procedure.   I am afraid this is a Canon problem but B&H will take it back. I am surprised B&H didn't catch it first off. 

EB
EOS 1DX and 1D Mk IV and several lenses!

Sreehariks29
Contributor
I am also facing same issue.. How did you solve this?

reynsteph
Apprentice
Unfortunately I did not fix the issue. I was able to return the camera to B&H and purchased a different used 80d from them that has been working great.
Announcements