cancel
Showing results for 
Search instead for 
Did you mean: 

70D using Diffuser - Flash button press does nothing

fr33zypop
New Contributor

I have used my diffuser on my old XSI for years and when I went to try it on my new 70D the camera Flash seems to disable. When this is install in the hotshoe and I try to press the flash button, nothing happens. Soon as I remove it the button works. 

 

1 ACCEPTED SOLUTION

kvbarkley
Honored Contributor

I think Cicopo is right, the camera thinks there is something that will block the pop-up flash and keeps it retracted. You might be able to figure out where the switch is and modify the diffuser to not hit it.

View solution in original post

5 REPLIES 5

cicopo
Esteemed Contributor

Not sure I understand the situation but IF you install something into the hotshoe it presses down a switch to prevent the built in flash from popping up. If it tried to pop up there would be a problem because something SHOULD be in it's way.

"A skill is developed through constant practice with a passion to improve, not bought."

kvbarkley
Honored Contributor

What is this thing called "Diffuser" is it something on the pop-up flash?  can you provide a link?

kvbarkley
Honored Contributor

I think Cicopo is right, the camera thinks there is something that will block the pop-up flash and keeps it retracted. You might be able to figure out where the switch is and modify the diffuser to not hit it.

fr33zypop
New Contributor
Thanks for your input. I'll give it a closer look at those contact points.