Showing results for 
Show  only  | Search instead for 
Did you mean: 

5d4 firmware


My brand new 5d4 came with firmware version 1.3.4, but I am unable to find any reference to this FW version. Everything that I can find refers to 1.3.3 as being the latest.



Me too - when I check I see on 1.303!   That's very curious...

cheers, TREVOR

Before you ask us, have you looked in the manual or on the Canon Support Site?
"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris


Did you buy the camera online?  

What camera model number is being reported in EXIF data of the image files?

"The right mouse button is your friend."


Purchased from B&H Photo, delivered 7/29/22. 


Do you have the model with Canon Log Firmware?

"The right mouse button is your friend."

I did not pay for a camera with Canon Log.

Since the camera is in the repair facility I am unable to determine what is does or does not have.

Thanks for your help

The 5D mk III has FW 1.3.4 available.

But a 5D mkIV with CanonLog might have 1.3.4 as Wadizzle suggests.

Why is a brand new camera purchased 7/29 at Canon for repair?  What happened?


Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~6D2 (v1.1.1) Retired ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

He might be getting it calibrated, a common necessity for DSLR AF.


The reason that it is in the shop is a long story. I'll try to make a condensed version.

I was able to select AF from my quick view screen on my 5d2 I wanted to have the same capability with my 5d4. There is a Rudy Winston YouTube that shows how to make it happen, well it would not happen on the 5d4 when I tried it. So, I contacted CITS and spoke to a rep, who after a back and forth discussion of try this, now try that, it still would not work. She then contacted somebody at her end who tried on a camera. After a few minutes she returned to me and said that the guy at her end couldn't make it happen either and that I should send it to Factory Service.  Waiting to hear back.