cancel
Showing results for 
Search instead for 
Did you mean: 

5D Mark III Depth-of-Field Preview button Error 40

nfcg21
Apprentice

Hi all,

When I press the depth-of-field preview button on my 5D3, an Error40 message appears on the screen. I've tried with and without different lenses, remapping the button to every other function and even turning off the button, and I still get the Error40 message in every scenario. I've tried with multiple OEM batteries. Has anyone else experienced this issue?

1 REPLY 1

Tronhard
Authority

From my own research, the Error 40 is an electrical issue.  The easiest thing is if it is related to a battery error.   The best thing to do is replace the battery with a known good battery, preferable an Canon original one and try to turn on the camera again.
Another possibility is that moisture has ingressed into the button seating when it was being pressed - from what you write, I suspect you use the DoF button fairly often(?).  That should not happen as the body is moisture-resistant. 

cheers Trevor

"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris
"A good swordsman is more important than a good sword" Amit Kalantri

Technique will always Outlast Tech - Me
Announcements