cancel
Showing results for 
Search instead for 
Did you mean: 

Canon rebel t6i - 18-55mm lens - AutoFocus not working

BGrFSH
New Contributor

The autofocus on my 18-55mm lens for my canon rebel T6i stopped working this weekend. The camera still works, takes pictures and manual focus works but the autofocus isn't functioning properly. I will press the button down to focus and it zooms in and out like it's trying to focus but never actually focuses itself on something it'll just zoom in and then out and won't let me take a picture. 

 

I tried a couple different things to see if it'd fix it but mechanically the lens is still working it seems like (ie. motor isn't broken) but it won't ever actually focus on something. 

 

Any suggestions are appreciated. 

3 REPLIES 3

ebiggs1
Forum Elite

Try this:

 

Take the lens off of your camera.

Put the lens in MF mode.

Twist the FOCUS ring (the tip of the lens) all the way to one side (extend it). You may hear a click noise or two, this is good, but don't FORCE the lens.

Twist the FOCUS ring all the way to the opposite side (retract it). Again, you may hear a couple of clicking noises. What we hope is happening is the focusing motor being put back into its proper place.

Put the lens back on the camera.

Put the lens in AF mode.

Turn the camera on.

Put the camera in AUTO or P mode.

Take a test photo.

EB
EOS 1DX and 1D Mk IV and several lenses!

BGrFSH
New Contributor

Hey there,

 

I tried this almost immediately after it stopped working and it didn't seem to do anything. 

 

Yesterday when I was trying out a couple things for the first time I got "Lens communication error clean electrical contacts" so I'd done so and it still didn't make a difference. 

 

Maybe this can help point a bit more of a direction towards the issue?

 

Thanks!

It is probably done.  Also not a good candidate for repair but you can call Canon as ask.

EB
EOS 1DX and 1D Mk IV and several lenses!