Showing results for 
Show  only  | Search instead for 
Did you mean: 

TS8051: Scanner driver problems under MacOS Catalina


I have been unable to scan successfully using my TS8051 since upgrading to Catalina.  Any attempt to scan results in the error: "Scanner reported an error - A required file is missing or corrupted, or settings are incorrect.  Try the installation again".


This happens over multiple Macs and all apps, whether the built-in MacOS scanner, Image Capture or the IJ Scan Utility.


I have tried removing and reinstalling the printer multiple times, and I have tried using the Apple Airprint drivers and the native Canon drivers.  Nothing works.


I can't believe I'm the only one having this problem.  Any ideas anyone?



Hi N1David,

Welcome to The Canon Forums!

We appreciate your participation, though we need to let you know that your product appears to be a model that is not supported by our team here at Canon USA.  The Canon Community Forum is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market.

If you live outside the United States, please click HERE and select your country to find support in your part of the world.

Feel free to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA

Thanks Tiffany - regrettably there is no forum for Canon support in Europe. Given that the drivers for the TS8051 are standard TS8000 drivers, I had expected that there may be other printers in the same series which had experienced the same problem.

I had lodged a support request with Canon UK, which has gone unanswered after a week, which is why I was looking for alternative means of support.

Best, David