Showing results for 
Show  only  | Search instead for 
Did you mean: 

TR5420 suddenly printing blank from my MAC and iPhone and it's in copy mode


I was printing last night with 9 pages and suddenly my last page came out blank. I tried to re-print and still blank. I tried from my MAC still printing blank. I reset my wifi and turn on/off the printer still in copy mode.

This morning I check the community about copy mode and printing blank. Tried all the possible solutions and still printing blank. I removed and re-install the printer and still printing blank and in copy mode even the test print was blank.

I don't know what to do anymore and I need to print stuff for my meeting tonight. Please help!!

I hope I find a solution soon.



Thanks for joining the conversation, jvillarin9569!

This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, click HERE search our knowledge base or register your Canon gear HERE to access additional support options.

Thanks and have a great day!