cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Printer prints coupons and basically nothing else

sillycrab
Apprentice

I used to be able to print anything on my MP620B using my MacBook Pro with OS X Snow Leopard and my son's Lenovo with Windows 7.  When I upgraded OS X to El Capitan, Canon has no corresponding driver for it so I saved my docs to be printed in Google Docs and accessed them in my son's laptop for printing.  At some point, I replaced the 4 small ink tanks (only the big black tank wasn't replaced).  Then I read in one forum where this poster said he downloaded a driver for the old OS X Mavericks although he has the OS X El Cap.  It worked for him.  I did the same thing and now the printer only spews out blank pages.  Even sending the print jobs from the Lenovo results in blank pages.  I tried the "Test Page" through the printer utility screen in both computers and I got a page with the 3 magenta bars blank.  I did the nozzle check, etc using the printer menu itself and it printed the test page ok (including magenta).  And now here's what makes me scratch my head:  I downloaded the coupon printer in the L'Oreal website in my MBP and printed a hair color product coupon and another coupon from the Walmart website.  Both coupons printed ok.  Why can't I print anything else?

1 REPLY 1

Michael
Product Expert
Product Expert

Hello.

 

Troubleshooting with our support group will be needed to narrow down the cause of your issue. Please contact our support group using the "Contact Us" link below for additional assistance.

This didn't answer your question or issue? Find more help at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Avatar
click here to view the press release
Announcements