Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pixma TS6420a printer does not recognize ink cartridges


I have a Canon TS6420a printer, purchased 10/2022, so just five months past the one year warranty.  When the black ink cartridge (260) ran out I put in a new Canon ink cartridge, but then got the error message 1430 “the ink cartridge cannot be recognized”.  I have tried three spent ink cartridges that I had lying around and get the same error messages.  I have cleaned the connectors as best I can.  Is there a solution to this problem, or does this relatively new printer go to a landfill?  I also have an HP Deskjet printer from 2006 that still works – just saying!




Have you tried this?  Opening the ink carrier and removing the cartridge.  Unplug the device.  Press and hold the power button for 30 sec.  Reinstall the cartridge.  Close the retention clip.  Reconnect the printer to power.  Press the power button to turn on.

Where did you buy the cartridge?  There are a lot of non genuine cartridges being sold on Amazon, etc.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thank you very much for your response, but it did not resolve the problem, still get support code 1430.  I purchased the ink cartridge online through Walmart where I have purchased all the previous cartridges that have worked.  It certainly looks like a true Canon cartridge.  Moreover, the previous spent cartridges all now give the same error message – I thought they would just be recognized as empty.  I could order a cartridge direct from Canon, do you think that is likely to work given that the old cartridges are no longer accepted?