Showing results for 
Search instead for 
Did you mean: 

Canon MX410 scan -- MP Navigator EX crashing


Hi all,


Would greatly appreciate help. Father passed away, trying to scan some physical photos to submit for the memorial, but it's not working:


This old MP Navigator EX 4.1 crashes upon launching from the Canon Solution Menu EX. I've gone online to


, but there's no MP Navigator software there. I've looked around online but haven't been able to find any relevant info.


I also tried scanning the photos onto USB but it seems it is only able to scan PDFs when it's USB. Why? (If this worked it would also be fine)


Could anybody help me? Thanks.



Hello, Isotopic_Bear,


Welcome to the Canon Community. We're sorry to hear about your loss, but we'd like to help as much as possible. 

So that the Community can help you better, we will need to know about any error messages you're seeing, and the Computer Operating System you're using (Windows Vista/7/8/10 or macOS 10.x), as well as the way you connect to your device (USB or networked via WiFi or Ethernet).

Any other details you'd like to give will only help the Community better understand your issue!


Thanks and have a great day!

Hi Stephen, thanks for the help. The computer is Mac OSX 10.13 High Sierra, and the printer’s connected to the computer via Ethernet (wired as far as I can tell)

When I try using USB, it’s a USB plugged into the printer. Then, turns out JPEGs are able to scan, but only in letter, A4, or legal size.

I moved some files around and tried to reinstall MP navigator EX. So now the MP navigator EX file is outside of the original directory is (where is it supposed to be?) but upon trying to directly click and launch it, it crashes immediately. This also happened previously when there was the option in the Canon Solution Menu EX to do “auto scan” or when I tried to initiate a scan from the printer at the very beginning (because it seems it was already connected). The MP navigator EX would launch and then “ quit unexpectedly.” I will paste the error message here

Here's the crash log that I pasted into pastebin:

Rising Star

Hi Isotopic_Bear,


I understand that when accessing MP Navigator EX the program immediately crashes. 


For MP Navigator to return to functionality on your computer the old software will need to be completely removed from your computer. Just the MP Navigator software is what needs to be removed.


Ensure it is removed from the following locations: Canon Utilities Folder | Desktop | Dock (at the bottom of the screen) |


You may have to go Force Quit and Quit MP Navigator from that location as well. Once the program is removed empty the trash and restart your computer.


After your computer has restarted you can try using an older driver to work on your operating system. There is not a certainty that this will work. Click HERE to access the Canon website for the MX410. Once on the website locate Operating System and adjust it to the most recent OS with drivers available. You will want to download and install the following drivers/software from the appropriate tabs:


Drivers: MX410 series Scanner Driver Ver. 17.7.1b (Mac) & ICA Driver Ver. 4.0.0(Mac)

Software: MP Navigator EX Ver. 4.1.4 (Mac)


Once the software is installed, open the MP Navigator EX program and attempt to perform a scan.

Hi Caemene,


Thank you! I will take the action of removing MP Navigator from my computer.


It looks like those drivers and software is only available if I select High Sierra 10.12. Is that okay, if my version is 10.13?


I will try it tomorrow when I get back to the location! (Am PST)


Additionally, is there a reason I can only scan Letter/A4/Legal size photos from the MX410 onto USB?


Thanks so much.

Hi Isotopic_Bear,


Using an older driver should not cause an issue with the system.


When scanning to USB, the printer can only scan in the sizes stated (Letter|A4|Legal); however, there are three formats that you can save the image in, which are: jpeg|PDF|compact PDF.