cancel
Showing results for 
Search instead for 
Did you mean: 

Canon MG5750 connected to mac with usb lead but wont connect

sandymoo
Apprentice

Hello , Im new to this printer. I  bought new inks and cleaned it up etc etc . Yesterday it worked fine but today it says the printer is not connected ? Ive tried printing emals and no luck , Ive tried printing photos and no joy .. am I missing a simple point ,it has paper and im NOT using wireless , ive switched it on and off again as well. 
thankyou 

 

1 REPLY 1

Patrick
Product Expert
Product Expert

Hi sandymoo,

 

Please follow these steps:

 

1.  Please click on the Apple in the upper left hand corner and then click on System Preferences.

 

2.  In System Preferences, please click on Printers & Scanners.

 

3.  In the Printers window, on the left hand side, click on the Canon printer 1 time and then click [-] at the bottom to remove it.

 

4.  Repeat until all Canon MG5700s are removed.

 

5.  Once complete, please click on the [+] at the bottom and re-add your MG5700 series printer.

 

When the printer is reinstalled, please attempt to print.

 

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Announcements