Showing results for 
Search instead for 
Did you mean: 

Cannot get printer to print WIRED

New Contributor

I'm trying to rid my life of WIFI, so I am trying to get my Pixma TS3122 to print using a USB cable, but can't do it. I have a Macbook Pro. I have been using this printer for about 2 years wirelessly. I have tried and tried and tried to find information on canon website, but it is hopeless. When I go into my preferences > Printers, the Canon is not even showing up. When I click on "Add" no Canon shows up. (I have the USB line plugged in.) 


Can anyone please help me? Thanks so much.




Esteemed Contributor


If your don't see the printer listed in System Preferences > Printers and Scanners, then it might not be installed.  


Try running the Master Set Up for the TS3122:

Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6

Reputable Contributor

Hi clarehatescanon.


Ensure the Macbook is plugged in to external power and charging.  Running a computer on battery power can cause the USB signal to be too low for the computer to detect the printer.


There have been cases where a printer will need to be set up first by wifi before Mac OS will recognize its drivers on a USB connection; if this happens to you, enable Direct Wireless Connect (the button with the picture of a cell phone) then print the TS3122's network information (the "i" button) to show the printer's direct connect wifi password.  Connect to the printer's network and register it as Airprint, then remove it, reconnect to your main network, and try setting it up again by USB.


Note: the drivers for Mac OS are provided by Apple.  If drivers are not available for the printer by WiFi, refer to Apple Support (non-Canon link: for help acquiring the drivers.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.