cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

recent Canon Connect iOS app refuses to operate without location information

f65f9d
Apprentice

We have a Canon 6d camera. We do not provide location information, nor do we want our activity farmed to Google (which the app also does).

The application outright refuses to function of location information is not provided. We will _never_ do this.

 

It complains: "Location information required to display the name of the network to which this smartphone is connected when connecting to the camera via Wi-Fi." This is nonsense. The app has been given "Local Network" access.

 

How do we either bypass this requirement or find out when this bug is fixed?

 

4 REPLIES 4

jrhoffman75
Legend

My 1D X Mark III is connected to Canon Connect.

I just tried an experiment:

1. in the iOS Privacy section I turned off Location Services for the app. Started up the app, turned on my camera and enabled network settings and Bluetooth settings. Selected connect to camera and everything worked fine.

2. my camera has built-in GPS so I imported two images into the phone. One straight from camera and the second I turned on the "remove location data" option in Canon Connect. One image showed the location data in the Photos camera roll and the second image did not.

3. I can't speak to anything Google related, but I don't see any setting in the app that involves Google. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

I wonder if our trouble comes from us having a 6D with no GPS. In the iOS settings for Camera Connect I've got: Location Never, Photos: ALl Photos, Bluetooth off, Local network on.

The Google stuff is in the "Regarding the Collection of information on usage Status" you need to agree to on using the app.

Trying the app on my phone (for the first time on this phone but I've clearly used it on the old phone, since it asks to reconnect) I get the above mentioned "Permission is not set correctly" and complaints about the location information.

This is before it even tries the actualy camera connection, so that may rul out the camera facilities.

I appear to have Camera Connect 3.1.1.

We're using the camera in infrastructure mode with the local wifi here. I might see if we can try using it as a hotspot/AP instead.

Greetings,

I had the same experience as John, but with Android.  You can set the app permissions as you wish.  Allowing location services is not required.   The phone connects to the camera which acts as a hotspot.  It is not location dependent.  

~Rick
Bay Area - CA


~R5 C (1.0.5.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It

jrhoffman75
Legend

I have 3.1.1.44. I turned off GPS on my camera and disabled the data collection permission. Location Services OFF. 

Still works. 

Register your camera on the Canon support site and give Canon support a call. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic
Announcements