cancel
Showing results for 
Search instead for 
Did you mean: 

Eos Utility problem

alexpado
Apprentice

Hi to all,

I have a problem with the Eos Utility Software.

I have the OS Windows 8, and I installed the last version of EOS Uility 2.12 compatibility with the new OS.

When I connect my EOS 5D MKIII or the 7D the EOS Utility not recognized the camera.

The drivers are installed , all the others programs works fine with the cameras.

Someone have a suggestion ? Smiley Happy

1 ACCEPTED SOLUTION

I was having the same issue with EOS Utility not seeing my D60.
In Device Manager, do you see any other devices other than your camera under "Portable Devices"? Under mine, I have listed 4 removable media drives "SD, CF, etc.) that corresponded to my All-in-one Internal USB2.0 connector Card Reader. Each slot is shown as a drive letter. I disabled all four drives by right clicking each one and choosing "Disable" Once that was complete I plugged the camera back in and started the Eos Utility. Camera was now fully recognized. I can still use the media slots even with each drive being disabled.
Good Luck
Rich

View solution in original post

132 REPLIES 132

On page 6 of the EOS utility Manual Ver 2 it states that on Windows 8 the EOS utility will not launch automatically when the camera is connected and turned on. I assume this would apply to Windows 10 also. 

 

That has been my experience.

 

There is a suggestion on the next page on how to (hopefully) fix this. I tried it but it didn't work. YMMV

 

EDIT: I can't remember if it's mentioned earlier in this thread, but you should invoke EOS Utility 2.

I did invoke EOS utility 2 and it made no diference.

 

The answer to my problem was to prevent my AVG antivirus from blocking the software. AVG did allow all my other Canon software to operate successfully without any problems.

 

Regards

Dennis

Kanitfastan
Contributor

My past troubles seemed to be similar (under W7).

My external USB-HD (WD20EARS...) driver destroyed the EOS driver. 

Solution: Disconnect every external USB device, deinstall all related drivers and SW. 

(Re-) Install step by step. After each step take a Windows Restore Point (so you can redo it).

First reinstall EOS driver. 

 

Worked (and still does so) in my case. Good luck!

 

EOS 5D Mark II, EOS Utility 2.14.10b
Windows 7&SP1, no other Hotfixes

"...  uninstall and delete all drivers for your camera ..."

 

The camera requires none and there are no drivers associated with it, from Canon.

EB
EOS 1DX and 1D Mk IV and several lenses!

https://support.avg.com/answers?id=906b00000004udqAAA   anyone using AVG, this helped alot and i got it back up and running.

 

 

che_hombre
Apprentice

Microsoft surreptitiously upgraded my Windows 7 to 10, which I did not want. I ended up reinstalled Windows 7. Canon's EOS utility 2.14.20, however, crashed on launching. What I finally was able to get it to work was to install 2.14.01, which was supposed to be for Windows XP. Hope this may help someone.

georg_m
Apprentice

same problem still exists:

 

my 5dsr is recognized normally as 5dsr on my usb2 ports. works fine with eos utility.

 

on the same machine on the usb 3 ports it is only recognized as MTP portable device by windows and does'nt work with eos utility.

 

tried all the suggested workarounds and fixes. no succes.

 

please fix the driver! otherwise the usb 3 plug is useless for me.

earpludesign
Apprentice

Having sincere trouble setting up Eos software with my canon camera , the camera settings and shooting element is greyed out , can,t seem to find even after updating from the website how to connect this part of the software , any ideas camera buddies!

kaliope74
Apprentice

My Canon Utilities on my windows 8.1 can't found a dppdll.dll to work it, I've copied on its place and doesn't work, help please! I want to use raw archives!

Download a fresh archive and re-install.

Announcements