Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Utility cannot connect to server in instructions


I'm following the instructions to try to set up the new web service on my 6D and 77D. For both of them the EOS utility in the manage web services section after asking for name/password says 'can not connect to server' and the program exits.

I got the latest version of EOS utility. This is on a Windows 10 computer that is up to date.

It would be nice if the program didn't crash out and instead stayed open.




When you first went to the site were you able to sign in or make an account ID in the process? Un-installing the EOS Utility software and then re-downloading from the web site and performing a full re-install may also resolve the issue you're having. 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Yes, I got an email from Canon saying welcome to a new account, etc, so that part worked. I already uninstalled the slightly older version and installed the latest version of the EOS utility.

As an experiment I typed in nonsense for username and password and it said the same 'cannot connect to server'. I wonder if the 'create an account by using your google account' is the part that doesn't work?

However, there is no way to log in to the until one registers a camera. So I can't check that is working. Sorry, the committee that designed this mess has really jacked it up 😠

The 6D's wifi setup menu has 'upload to web service' which is probably what this needs to be set as. How do I set it up without the nonworking EOS Utility? Is there a way to set it up directly in the camera's menus?

Hi, try today. It's working.

EOS 6D, EF 24-105 mm 1:4 L IS USM, EF 50mm 1:1,8 II, Speedlite 580 EX II

True, works for me, thank you!


OK, great, so it suddenly worked today. I guess they fixed something, probably the sign in with google.


Now the Android app won't run without permission to scrape my contact list. Allow access to the phone storage and pictures? Sure, that's perfectly reasonable. May we read off your contact list? No. WHAT AN INCREDIBLE WASTE OF MY TIME TRYING TO GET THIS WORKING.

Hi, my mobile app running without permission to my contacts.

EOS 6D, EF 24-105 mm 1:4 L IS USM, EF 50mm 1:1,8 II, Speedlite 580 EX II


I get the same error with my 6D mk II.  Reinstalled utility, rebooted computer, rebooted camera, etc.  I can download photos and run the camera remotely, but can't connect to the server. I assume this is just a case of poor quality control on Canon's part.  

click here to view the press release