cancel
Showing results for 
Search instead for 
Did you mean: 

EOS Utility 2 Sees but won't download from 40D

Methos65
New Contributor

Hello.

I haven't used my 40D in quite some time and now have a new computer running Windows 10.

I installed EOS util 2 and it can see the images on my CF card.  However, when I select them and try to download, all I get is "busy" flashing in red in the bottom left corner of the window and nothing happens.  The same thing happens if I try to go to Preferences in the Utility.

 

Anyone experienced this or have an idea?  Do I need an older version of EOS util 2 perhaps?  I didn't see an available firmware update on the Canon site.

 

Thanks for reading.

 

Here are the versions I'm using:

EOS Utility 2 2.14.20

Canon 40D Firmware 1.0.8

Windows 10 Pro ver. 20H2

1 ACCEPTED SOLUTION

After more thorough Googling, I found a solution that works.

 

Go to the Startup folder on my laptop and edit the NAME of the shortcut in the startup folder to start "eos utility 2" (leave the rest of the shortcut in place).  It seems to bring up the utility in a different mode (or another version of it Smiley Happy) that will recognize the camera as soon as you conect it (and switch it on Smiley Happy).

 

Hope that helps somebody else!

 

Keep shooting!!

View solution in original post

2 REPLIES 2

Methos65
New Contributor

I've tried rebooting my laptop and also ensuring all other programs are closed.

Attached are screenshots showing what happens.

When I first start without my camera turned on, I get this image.

Screenshot 2021-07-23 105126.png

 

When I turn my camera on, I can select images.  When I click download, the "Busy" message flashes in the bottom left corner but nothing happens and the images are not downloaded.  See the attached image.

Picture_busy.png

 

After more thorough Googling, I found a solution that works.

 

Go to the Startup folder on my laptop and edit the NAME of the shortcut in the startup folder to start "eos utility 2" (leave the rest of the shortcut in place).  It seems to bring up the utility in a different mode (or another version of it Smiley Happy) that will recognize the camera as soon as you conect it (and switch it on Smiley Happy).

 

Hope that helps somebody else!

 

Keep shooting!!

View solution in original post