Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS-1DS Mark II looking for firmware 1.1.6


I just bought a pristine 1Ds MkII from an eBay seller out of NM. 

The camera's firmware is 1.1.1 and I'd really like to upgrade the firmware to 1.1.6 so that the camera will recognize larger capacity memory cards.

I've searched far and wide. Those searches led me to a few links for the firmware but those links are no longer active. If you can provide me with an active link where I can download firmware version 1.1.6 I would be most grateful.



Sure. PM sent.

Make sure that the file has the right SHA256 checksum. If the checksum is right the file is intact.You can compare here from my page

View solution in original post



I just checked and I have all the firmware updated for the EOS R, RP, 5D MkII and 40D

Seems you didn't get the firmware update for 1Ds II I sent you.


Good post dpsaiz, I took recently acquired a 1Dsmark ii, it's firmware version is 1.1.4. 

My query is do you need to update each firmware update to reach the final 1.1.6. or does the 1.1.6. firmware version contain the previous updates to (for example the 1.1.5. update, if there was one?).

I'd appreciate the advice, and kindly ask Peter if you could send me the firmware too, thankyou.

Best regards to everyone here, I've just joined while searching for help on the topic 👍

You can always update to the most recent firmware.

I tried to send you a PM, but I just get an error message.

Thankyou for trying to PM, there's nothing there, I'll keep looking in the future to update, cheers Peter 👍

I apologize for not replying sooner. Every time I tried to log in the website kept throwing an 'unexpected error' message. I couldn't log in for day and a half.

I am glad the team here was able to assist. One thing I found out is the 1Ds will take a larger capacity CF or SD card but you'll have to format it as FAT32 on your computer. If you format it on the camera you'll get a partition no larger than 9GB.  

I had to play around with that for a while before I got it to work. Additionally the firmware update will cause the write speed to be slower to the SD card. I don't shoot sports or action so I don't care so much for the write speed. By the time have have the next shot metered and composed the camera has completed writing to the card. 

BTW, my rig tips the scale at 5.6 lbs.; the EOS 1Ds Mk II + EF 24-70mm f/2.8 L II USM + CPS strap. Its a beast and it'll likely outlast me.

"Additionally the firmware update will cause the write speed to be slower to the SD card."

Try a low level format of the SD card. I couldn't find the option in 1Ds II manual but you may have another Canon?


It didn't occur to me to use the EOS R. I popped the SD card into my Windows 11 PC and did a LLF with Disk Management. There's no real way for me to test the write speed from the buffer to the SD card. As I mentioned before I don't shoot action photos. Mostly still life so write speed isn't an issue unless I was at a MotoGP event or something of that nature.