Showing results for 
Show  only  | Search instead for 
Did you mean: 

DPP 4 Mouse problem


I have a very annoying problem with how the mouse behaves in DPP 4.


On the very first time after opening the DPP 4 from my desktop, and double clicking to maximize a thumb nail, all the menu button on top of the screen could be activated with a single mouse click.


If I close the window and open another picture (Or the same picture) all the menu button would then need a double click to activate. But, after the initial double clicking activation, all buttons will work with a single click until the window is closed.


Only way to make the menu buttons at the very top row of the window to work with a single mouse click is to first highlight the thumb nail and then open it by using the Edit Image button which is located at the second top row from the window. Or close the DPP 4 all together and open the program again form the desk top and then the single click would only work for the very first picture I doulbe clicking.


Things I have tried are------ fresh install window7 64 bit with nothing else but video driver and DPP 4 ; different mouse drivers ; change user account control to never notify then reinstall DPP 4 ; tried different versions of DPP 4 ……..


I believe the top menu buttons should work with a single click? Any help in your know how of a fix would be much appreciated.


Thank you for reading my long post.



I have not double clicked in a DPP preview for a long while.  Doing so opens a second window, an editing window,  which I don’t like.

"The right mouse button is your friend."


I have DPP 4.7.1 and 4.7.2 installed, two different machines, both W10 64bit build 1709.  I've tried t reproduce the behavior you mention, but am unalbe to do so thus far.


The Menu buttons at the top of the program window get focus when I move the mouse pointer and hover over any of the menus.  The context menus appears with a single click. 


This is also true if I select a root folder in the navigation pane that doesn't contain images, then close and re-open the program. Once again, my menus get focus when I move the mouse and hover, then single click gives me the context menu,


I tried with the second menu bar expanded or hidden as well.  Still working. 


Video and mouse driivers are where I would have looked first as well.  Your fresh install of the OS should have resolved the behavior.  Afraid I don't have any windows 7 VM's to test on.  You have either found a bug or are overlooking something simple.  Might be worth while to contact support. 



Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

First of all, thank you guys for your response.


Rick, what if you double click the thumb nail to open  the image in a new window, does the mouse behave the same way after that ? Or it then needs a double click at the menu button to open a sub menu.


Thank you.


Same behavior.  The photo opens, the menu items get focus if I move the mouse pointer over one or more of them.  Single click displays the context menu. 

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Thank you, much appreciated.

If possible, can you try testing in another environment?  Does the mouse or keyboard have any vendor utilites that allow customization? (Programmable buttons, shortcuts, etc).  Its got to be something simple.   

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

That's exactly what I am going to do next-------fresh install the OS in another machine and the DPP4. Doing so will eliminate a Win7 installation disc problem. because at the moment, the target machine has a copy of DDP4 working with a single mouse click.. However, I can't be sure which OS installation disc was used on the target machine a year ago.


I also have a DPP 4 on board of a laptop running win7 64x, it also needs a couble click for the same thing BTW.