Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS utility fails to install on Mac OS High Sierra


Hi forum,


I have been hunting around for a solution to this problem for a long time with no success.



Mac Pro (Late 2013) with 2.7 gHz 12 core, 64 GB RAM

OS 10.13.4


I have tried both EOS Utility installers 2.14.3 (the one listed for my 70D) and 3.8.20 (the one that is a 64bit app that should work on my Mac).


What happens:

  1. Download EOS installer .zip file - SUCCESS
  2. Unzip the DMG file - SUCCESS
  3. Open the DMG file and double-click to install -   a window pops up that says "extracting files" with a progress bar. The progress bar completes, the window closes, and nothing else happens. FAIL


Having watched approximately 14 YouTube videos purporting to help me get EOS Utility working on my Mac, the next thing that should happen is a window popping up asking me to choose my language/region. That never happens.


I'm pretty tech savvy, having worked in testing and program management in the software development field for 15 years. I am not a developer, or I'd probably be able to run this thing in some kind of debug mode and figure out what part of the installer is failing. 


Any help, tips, or tricks would be most appreciated!






Well folks, I finally hacked this to work. 


What I did:


Created a new Admin user on the Mac. Granted that user access to shared folders.

Logged in to the admin user, downloaded the EOS installer, and the installer actually ran!

Logged back into the original user account and the apps were all sitting there in my Applications folder.


Since I've seen several others that had this problem, I figured I'd share what finally worked for me.




Thank you! This worked for me!

After MUCH struggle I finally found your short sweet answer and it works! Thank you!

This worked for me! Deleted the new admin user afterward and the applications still worked.


When software on a mac wont run for one user account, but will run for a different user account, it usually implies there's a corrupt ".plist" file.


Mac's store appliation "preferences" in files called "plist" files (plist = preference list).


These files are generally stored in the Library -> Preferences folder located under your home folder.


Note that most modern versions of macOS hide the "Library" folder in Finder.  To access it, launch Finder and in the menubar across the top of the screen, select the "Go" pull-down menu, then press-and-hold the "option" key on the keyboard and the "Library" choice will appear (it will hide as soon as you release the "option" key).


Once inside the "Library" folder, you can find the "Preferences" folder where you'll find a lot of ".plist" files for your applictions.  The names usually take the form of com.<vendor>.<application name>.plist.  


for example: is the preference list for DPP4.


If a plist file is missing, an application will simply create a new version of it with default values.  You don't need to delete the file... just move it out of the "Preferences" folder (e.g. drag it to your Desktop temporarily).  Then re-launch the program you had an issue with to see it works.  If it DOES work, then the plist file was damaged... just send it to trash.  if it does NOT fix the issue, then the plist file was probably fine and you can drag it back to the Preferences folder.



Tim Campbell
5D III, 5D IV, 60Da