Showing results for 
Search instead for 
Did you mean: 

CCC showed the MF button... twice.


Just bought a lovely M5. Fantastic camera. There are, indeed, are some things left to do on the software side... to put it mildly. We know about the EOS Utility woes (I'm a mac user). But there are some other areas where Canon fumbles in the literal sense. Dropping the ball. 


I bought this LOVELY macro together with the M5. A 28mm with LED lights built into it. Perfect for a day outdoors with a mini tripod, in case the fish won't bite.


And I can't use it.  


See, in order to do some focus stacking later on I need to adjust the focus from an app, so that I don't disturb the camera. DSLR Controller is one option for my old 5DmkII, Magic Lantern is another. Nice stacking automation there, move the focus half a millimeter and then take the next shot, repeat 50 times. Well well. Old platform, but still going strong. Back to my M5. 


1) EOS Utility won't talk to the M5 - can't go there. 

2) DSLR Controller (or Helicon Remote for that matter) cannot talk to the M5 (but I can't really blame Canon there... can I?) 

3) There is no native focus stacking on the camera, like on Olympus TG-4. Well, that's a Product decision from Canon. 


But there is one weird thing. 


TWICE, a MF button has shown up in Canon Camera Connect. When it does, I can take stacked pictures by manually (from the app) adjusting the focus using <<<, <<, < , >, >>, >>> buttons. No automatics, no ability to say "press >>, take picture, repeat 50 times". But still usable. Or barely usable anyway.


I have no idea what triggered the appearance of the MF button.


Deep inside I have doubt that Canon will be able to get their software in order since their software gives an incredible "design by accident" impression, but hey... getting that MF button when I need it would be a good start while I wait for DSLR Controller to support the M5. 


So, does anyone know how to make this darned MF button show up?

Have a happy new year everybody, 

/Bengt Berg 




DId you try to call the Canon help line?

Never really thought about that Smiley Very Happy I have precious few experiences of an anonymous helpdesk being better than enthusiasts on a forum. On the other hand, this is a new camera model and people might not have found the last quirks in it... I reported the issue over the web at Canon Sweden anyway. 


SO all you people with M5's, I would be happy to hear what you've found. 


Best Regards, 

/Bengt Berg 

OK, this is getting increasingly hilarious. Smiley Happy


I am now in email contact with Canon. The below is the shorthand executive report of it... trying to sort it out since the issues were intermingled in the conversation (fewer emails in reality than the shorthand below). 


Canon: Yes, it should work on CCC. 

Me: No it doesn't

Canon: Make sure you have selected Manual focus on the lens

Me: The M5 uses EF-M lenses. No focus selection on those lenses. But sure, I can select MF on the camera itself. 

Me: OK, tried that. Didn't work. 

Canon: You should make sure the "Show AF Button" is selected in CCC. 

Me: Did that. No change. 

Canon: You should also install a new Eos Utility on your computer. 

Me: OK, thanks. Doing that. 

Me: Tried that. Didn't work. And I can only pair over USB despite having WIFI in both camera and Computer. I can download pictures and set some camera preferences, but not do any remote shooting. 

Me: I live some 700 meters from Canon Sweden head office. I can visit you guys in your reception, to show you this. 


...still waiting for an answer. You people see why I prefer to ask for help at enthusiast forums?