Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon xa50 covert mxf files problem



how do i transfer 4K XF-AVC footage from the canon xa50 mxf files to movie studio 17 which won't accept mxf files


Ive tried various file converters videoproc ect which converts the video but im hearing no audio after conversion but i am getting video & audio on the camera & canon xf utility


any suggestions as to how i can fix the problem?


Nobody using the canon xa50?

Hi, manley.

Welcome to the Canon Forums!


The Forums aren't intended for immediate assistance. If your question is of an urgent nature, click HERE to visit your My Canon Account to discover your personalized support options.


If you're outside of the USA, please click HERE to find your support options. 


Ok i thought this was a help forum sorry, ive already spoken to canon about the issue but im still no further on 

The Canon Community Forums are intended for your peers to be able to help you. 


Your initial post was less than 24 hours ago. 


If you need help immediately, we advise you to reach out to either your editing software support or Camcorder support. The community doesn't work in real-time. 

Missing audio is usually a codec problem. I had the same issue with AVCHD files. Recording in MP4 format will usually fix these issues.


For existing files you can try converting your MXF files to MP4 files for editing with one of the many utilities available. I often use VLC Media Player for this but I haven't used it for 4k conversions I must admit.

Thanks for the reply


yes i thought it may be


I bought the camera to film in 4k though you see ive tried conveting the files in videoproc but still no audio 

I just tried a test record in 4k MXF on my Mac and it played fine in VLC media player.


I was also able to convert it to MP4 format keeping the original video stream but converting the audio to AAC.

yes ive heard someone else mention no issue on mac im using windows 10 ive been sat all day trying to sort out the issue i have to edit some footage as ive just bought the camera but no luck 


i get no audio if i open a 4k file in vlc player also its odd but using the canon xf utility all is fine very frustrating

I fired up my Windows 10 PC tried loading the file into DaVinci Resolve (free version) and the audio played ok. So it looks like Resolve has the right codecs.


There is a bit of a learning curve to get productive in Resolve so it may not be the ideal editing solution for you.

Enter for a chance to win