cancel
Showing results for 
Search instead for 
Did you mean: 

Canon HG20 Trouble Importing to iMovie

messyj232
Apprentice

Hello Canon Community!

I have an older camcorder (HG20). I used to use it a lot, but have not used it in some time. Anywho, I used it the other day for the first time in a year (or two?) and I am unable to import video from the camcorder into iMovie. I did a couple of different things, but had no luck.

First, I just dragged and dropped the files (AVCHD) from the camcorder onto my desktop. Even though they kind of open, they take forever to import into iMovie. I gave it at least 2 hours the other day (and the status bar did not change) before I gave up.

Second, I tried directly importing from the camera to iMovie. I let it run overnight, with no change in the status bar before quitting iMovie. (Even though the movie did appear, I could not edit it, and it was very choppy).

Any help would be greatly appreciated!

Mac OS is MacOS High Sierra (10.13.3). MBP 17 inch, late 2011.

 

- Jon

6 REPLIES 6

VideoGeek
Mentor

Are the videos stored on the internal memory or an SD card?  When you dragged and dropped did you drag the entire folder and not just the contents of the folder?  You can download MPEG Streamclip and use it to view the files or at least the mp4 files.

They are stored internally. I dragged the entire file onto my desktop. I am hearing, through all this research, that OSX High Sierra is unable to read these file types...

Are they .MTS or .mp4 files?

Yes, there are .MTS files. I can open in VLC but for some reason am unable to convert to .MOV. I am currently trying an application called HandBrake to do the conversion.

I've had this camcorder for more than 5 years and never had a problem until the updated OS!

I will let you know how HandBrake works out for me!

HandBrake worked beautifully. Problem solved!

Good choice, Handbrake is good.  I also use MPEG Streamclip from Squared 5.  

Announcements

07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500