Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't Access CRM Files in Premiere Pro (PLEASE HELP) - C70


I'm hoping someone here has used Adobe which is supposed to support Canon RAW light and can explain how this is done because Adobe support has no idea about this.

I have the C70 and recorded footage in RAW LT format. Everything on the SD card looks good, CRM files saved accordingly in the directory, which was correctly copied/ pasted on to my machine running Windows 11. I am new to Premiere, I don't know a way to import files other than to select import, and navigate to the appropriate folder on the local device, however, when I do so, I only see files recorded in XF-AVC format. Adobe support had me check the filter button on the import screen and make sure that "All Supported Files" was selected. The CRM files are in the directory, further down when you drill down into MainFolder>CRM>REEL_NNN but the files in this folder are not being picked up by Premiere. What more is needed, thanks?

PXL_20230812_144929542~2.jpgIf you look at this directory "Dump 1", inside it's just the entire contexts of a properly formated card that has plenty of CRM in files nested properly. Why don't I see them?

Please and thanks friends.




If "not being picked up" means not seen or detected by Premiere and you have the filter set to all files, then I might conclude the format does not appear to be supported.  I'll take a look at Adobe's site.  

**I verified the format is supported.  Click on the wrench menu and look for a setting called "High Quality Playback".  Also try copying the file(s) to a local disk.  Then set the .CRM file association to Premiere.

There is a very knowledgeable C70 user here, but he uses MAC and Final Cut Pro.  I've just got with DaVinci Resolve.  

Have you tried Canon's Cinema RAW Development?  Not as a substitute, but to test with.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It

Yes that conclusion seems accurate but I could have sworn it was supported:

I can try canons cinema raw development as a trial thanks for the suggestion. Although I'm chalk full of technical difficulties atm my laptops network adapter just failed so if I can download the installation to my phone then port it over I'll be able to install.

As for the Premiere, Adobe wanted to log into my machine to reinstall all the software, look at permissions, third party plug in, etc, which they couldn't do because of the network adapter issue. So it may also be that it works and there is no issue, I just can't fix it right now until I get home so this canon cinema raw idea is good just so I can feel confident continuing to shoot. 

It would be enough to know that it does and should work (Premiere) automatically and that my issue is bizarre.

I wish I could help more but.... as far as I can see, your issue is bizarre.

I use my C70 with PP on Windows 10, and I have actually tested every file format the camera can create, and they have all worked for me with no issue.

So, I don't have many suggestions..

  • It looks like your PP is up to date, but check anyway.  I'm using 23.5.0
  • I have a bunch of Canon utilities installed.  I can't remember what they all are, or when I installed them, but having the right Canon package installed *might* make a difference.  I have Canon XF utility; Digital Photo Professional; EOS Utility (versions 1, 2, and 3); Canon XF-AVC decoder; EOS Webcam Utility.  Most (or all) of those are red herrings, but I can't swear that one of them didn't install some extra file decoder.

Well, good luck...

If you want to see my review of the C70, it's here:

I do actually check out all the formats.  There's even a cheat sheet for the bitrates etc.

How do you install the canon utilities?

It's a long time since I installed them, but basically I downloaded them from the support site and installed them.  I have a feeling I had to Google a bit for one of them.

UK support site:


I verified .CRM support about 15 min after my last post and see you posted 3 min later.  So our posts crossed.  🙂

The file type is supported.  You won't have problems as long as the computer has a decent amount of memory, processing power and good video card/GPU.  I'm sure you'll find the issue once you return home.   

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It

I'm sure I will to. The files are fine verified with the software you recommended thanks.

Files check out.  That is re-assuring then.  😀

Hope the network adapter thing is software and not a hardware issue.  

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It