Showing results for 
Show  only  | Search instead for 
Did you mean: 

TS9521C Connected but Not Responding, Now Won't Re-add to Mac OSx Sonoma 14.2.1


I am about to lose it with my Canon TS9521C printer.  

I installed this printer initially and got it working no problem.  The next time I went to use it, the printer says Wifi connection is 100% and my computer says it's connected, but I get the "Printer Not Responding" message on my computer.  I've reset the computer, reset the printer, disconnected and reconnected to Wifi, turned off the ipv6 settings... no luck.

I then try to uninstall the printer and now it won't reinstall - says the printer is detected via Wifi about 50% of the time and when it is detected, it won't connect.  I now cannot re-add this printer to my computer.  I've tried also connecting via LAN and still won't work.

This is now my third round with this printer.  The first time I uninstalled it and tried to reinstall, it took me 3 hours of just random trial and error.  Why on earth is this printer impossible to connect?



Thanks for joining the conversation, pineappleshark4!

So that the Community can help you better, we need to know exactly which operating system is running on your computer (i.e. Windows or macOS, and which version thereof). That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

I am using a 2021 MacBook Pro operating on OS Sonoma 14.2.1


I am having the same problem with the TS9521C and my laptop OS 13.2.  I spent hours and hours trying to get the printer to work.  Then I took to back to Best Buy and 2 Geek Squad specialists couldn't get it to work with my Macbook Pro.   It appears there is a firmware update needed for the printer... If that is the issue, there does not appear to be a way to update it because the printer won't connect to the internet through my computer.  Hoping Canon replies to this thread and solves both of our problems.   This is the first time in 30+ years I've not been able to set up a printer.  

It's such a bummer.  I ended up buying a printer cable and now can only use the printer if it's hardwired.

Mine doesn't even work with USB cable.  If a Canon rep doesn't respond to this thread, I'll return the printer and buy an Epson.  I'm going to give it one more try before I do that.  So frustrating that there is no way to talk to a human at Canon...just an endless loop through their website.  UGH