Showing results for 
Search instead for 
Did you mean: 

MG2922 Changed Routers Cannot Get WiFi Setup

New Contributor

I have a Canon MG2922. I just got a new router and now I cannot get my printer to connect to the internet to print. I tried holding the wifi button down like it said in the manual. The amber light blinks then the blue wifi light blinks but then nothing happens. I tried downloading the driver again from the Canon website. I tried diong a manual set up from and after I download the file it tells me that the software developer needs to update their files to be compatable. I have MacOS Big Sur 11.4 which according to the Canon website should be compatible. Plus it worked before I changed routers.  I need help setting up the printer to my network. Thank you. 


Product Expert
Product Expert

Hi melikecookies,


There is an app that we can use to perform Wi-Fi setup.


Please download the Canon PRINT Inkjet/SELPHY app on your mobile device (cell phone or tablet).


Once that app is installed, if it is open, please close the app.


Next, please hold down the Wi-Fi button on your PIXMA MG2922 until the error light (next to the triangle) blinks 2 times and then let it go.


The Wi-Fi light should be blinking now.


On your mobile device, if you are using iOS, please go to the main screen and select Settings.  In Settings, choose Wi-Fi.
If you are using an Android device, please go to the main screen and select Settings.  In Settings, select Networks or Connections and then choose Wi-Fi.


In the list of wireless networks, select the Canon network.


Once your device is connected to the Canon network, please open the Canon PRINT app that you just installed.


"Do you want to search" will appear, choose Yes.


Select your home's wireless network name and then enter your Wi-Fi password.


Your PIXMA MG2922 will be connected to your Wi-Fi.







Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.