cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SX60 HS built in flash not working. All camera settings verified. Flash icon indicates flash on.

Mdf
Apprentice

New SX60 flash is not working in any mode.  In Program mode I have the flash set to always fire.  I verified all the flash menu settings.  I inspected the external flash hot shoe and the small pressure switch seems to function fine.  I used an external flash and it fires as expected.  Any ideas?

7 REPLIES 7

John_
Authority

What external flash did you use? 

If it is not a setting or the tiny switch in the hot shoe rail is not stuck then you have an internal problem which will require service hopefully under warranty.

Just for drill try performing a reset to defaults thruogh the settings menu too

The external flash is an ancient one I had from film camera days.

 

I forgot to mention I did a reset as part of my trouble shooting.  I contacted Canon support and they had nothing to suggest.  They just said send it in and they'll look at it.  

 

I guess that's my last option.

 

thanks for trying.

 

Yes sending it in would be the only thing left and unless the flash you used was on the list of suggested flash units it will void the warranty if any. Since you said film days I doubt it is.

Good to know, but the internal flash never worked.  The external flash was tried to see if the camera was even trying to flash.   They better cover it.

Yes just dont provide them a reason not to cover it if you know what I mean

10-4. Thanks again!

Your welcome and good luck to you

Avatar
click here to view the gallery
Announcements