cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Powershot SX70 hs won't turn on after trying to use my cel phone as a remote

charleylyman
Apprentice

My camera needs some sort of drastic re-set. It won't turn on.

 

Even after taking out the battery, putting it back in, charging the battery and even trying a new battery, I can't get the camera to turn on. This is after a series of glitches I had experienced right before. My suspicion is it has something to do with the bluetooth/celphone/remote feature.

 

It began when I was setting up my cell phone to control the camera by remote control (pp. 183 & 184 in the Advanced User Guide). I connected the camera and my smartphone and after a few moments, the image on the camera froze. The camera was unresponsive. I couldn't fire another shot, zoom in or out or even turn the camera off. This happened two other times while I was experimenting with the remote featue.

 

So, I would take the battery out, slapped it back in and things seemed okay. I continued learning about the feature, then I found out that the remote feature can't be used for time-lapse photography. I had wanted to be able to do several time lapse videos without touching the camera. So, no big deal. I figured that is how it goes and it didn't bother me.

 

Later, I set up a time lapse and two hours later found I got no results. I figured I had made a mistake, so I set up another two hour time lapese. This is when I found my camera off and I haven't gotten it to turn on sine. Please help. I love this camera.

 

Thanks. Charley

5 REPLIES 5

BurnUnit
Whiz

Bear in mind that there are also switches for the battery door and the memory card door. They can sometimes get a bit wonky or out of adjustment and not tell the camera when the door(s) are fully closed. In which case the camera will not power up.

 

Also, are you using a full sized SD card or a Micro SD cad with an adapter?

Good points, will it turn on by pressing the Play button? Turn off your phone and try it...it would be odd that your phone is preventing it from turning on but worth a try.

Remove the SD card and try it

If it is the battery door switch it will need service. Check the battery door for damage.

Lastly, remove the battery and hold down the power button for about 30 seconds and try it

 

Pressing the play button was the second thing I tried after the power button wouldn't work. I turned off the phone, but that didn't do the trick. It's my suspicion though, that the phone and camera link led to the problem. It seems that the camera's performance seemed to erode until it gave up trying at all.

 

Tried removing the SD card. No luck. Same for 30 seconds of pressing the power button.

 

This is such a bummer. I'm in Montana and the sunset/sunrises this time of year are incredible. Plus, we have four bald eagles hanging out near the lake that my place of work sits on. Frustrating on many levels.

It does't look like there  is any damage to the battery or memory card doors. I buy local and brought it to my local store, where the owner was kind enough to unpackage a brand new battery to try it out. It's he that suggested I come to this forum. I'm using a full-size SD card. Thanks for your reply.

Chriskchan2003
Apprentice

Problem is not what you expected. It is a defect with PowerShot cameras mine is a SX540. On/off switch stop working. I hardly use this. Only when I insert a fully charged battery it work. But once I turn off it stopped working.  And if battery is not fully charged it does not work. Canon use the same feature for battery door.  Shame on Canon. I will dump this and buy a Sony

Announcements
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!