Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Powershot SX30is shutter closed due to wrong illuminaton measurement ?


Didn't use my Canon Powershot SX30is for some year.


It was working fine before, didn't fall, no dust.


Now I just got it out of the drawer to take some photos.


Camera starts up, can playback, all seems to work fine, but shutter stays closed and a dark picture is shown on the display.


If I take a picture, camera focusses and takes a black picture.


CCD seems to work fine as slight straylight reflexes are seen on the dispaly iif I play with a flashlight in front of the camera.


Shutter itself seems to be mechanically OK as during startup the shutter shortly opens.


It seems there is a problem with the illumination measurement ( sensor constantly outputs too high value ? )


Does anyboday have a clue what to do ?


Thanks so much !






Ensure you are uing a fully charged battery

Reset the camera's settings to defaults

Test with a different SD card of known quality


If none of these help, your camera will need service or replacement.  Since it was released in 2009.... probably replacement.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Hi Rick,


thanks for the tips.

Battery is fully charged, I tried with a second fully chraged battery as well -> same.

Also I reset the settings to default -> same.

Tried different SD Cards, also without SD Card -> same.


Wondering what is the problem.

How is the ambient light measured ?

Where is the sensor for it ?


Best Regards,





How is the ambient light measured ?

With the sensor through the lens.


Where is the sensor for it ?

The main sensor.


If charging the camera a few times and power cycling the camera does not bring it back, it will need to be replaced.