Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't setup my Powershot G7X Mark II to the Web service


I can not set up my camera for the web service.

I do the following:

1. On the camera: click "Upload to Web service" and enter my E-Mail-Adresse and a 4-digit code for verification on setup

3. Receive the canon-Email with the setup-link

4. Click the link and enter the 4-digit code in my browser

5. Error message in my browser: Camera link failed. Select from the Camera Wi-Fi menu and reset.


I have tried this several times and tried also an other wlan accesspoint. Always the same error message.

Any suggestions?



I'm also having the exact same problem. even though I did previously have full wireless access to both Canon Image Gateway and Irista but for some unknown reason, the camera will no longer establish a link.


Iv'e tried resetting EVERYTHING but camera will no longer connect to the web. Have also tried disabling my Win10 firewall and restarted the PC many times but camerastill will not establish a link to online services. 


I know its not a wifi problem on my end, as I can still transfer photos wirelessly between the G7X Mark II and my Win10 PC via Canon's "image transfer utillity' program. 


One of the selling points for me when I bought this same camera, was for it's wifi capabilities. So is VERY DISAPPOINTING to keep running into these ongoing wifi issues.


Hopefully someone will be able to help us both......


This is the message that keeps coming up on my computer. When I select the “update web services” option on the camera (the icon showed on this screen shot) all that happens is I have to re-start the whole process of trying to establish a connection to the web services, only to end up back at the same error message.....



Yes, I can confirm that, its no wifi problem. I can connect to the camera-connect-app on my smartphone. I can transfer fotos to the app. Only the connection to the webservice is not working.

G'Day again


I have tried again this morning,(19/08/18) to set up a wireless link to Canon online web web services (just in case it was a problem with the Canon Image Gateway server), but same problem still persists!


I have also checked that the camera can still transfer images to my iPhone and my iPad and my Win10 PC. Can verify that camera is able to transfer photos to all of the above devices. I can also still view my previously uploaded photos on both the Canon Image Gateway "Online Photo Album" and the Canon "Irista" photo storage site.


I can still upload new photos and videos (to both of the above sites) via direct upload from my computer. So I'm stuffed if I know what is stopping the camera from establishing a wireless connection to both of these sites ????


Hopefully a "wise one' will be able to help Smiley Happy



I'm having the same problem with my brand new Powershot SX730. All my various attempts to set up WiFi connectivity, using 2 different PCs, a mobile phone, 5 different browsers and 2 different networks all result in "An unexpected error has occurred. Please retry login. Some browsers may show this screen if you click a button twice or use the browser feature to create a new window."


I did get a call back from Canon this morning suggesting that I check the date and time settings because, apparently, they'd only been able to reproduce the problem that way and the setup involves a digital certificate and an incorrect time. Needless to say, the time, date, time zone and daylight savings settings were correct and matched between the camera and PC.

I tried again today to connect the camera with the web service and today it worked perfectly! I could do the settings and then upload from camera to irista and image gateway.

I do not know why it worked today. I used the same computer, the same browser and the same wifi like the last time.

I really hope that stays that way!

Now that is bizzarre as I was about to post that I was able to connect successfully too last night. I had assumed it was because I'd tried one more thing as an experiment, switching manual time zone selection to automatic but now sounds like something was broken in the gateway and was fixed!



Camera is now, once more, able to connect to the Canon Image Gateway site! 

Seems to have been a server problem on the Gateway server end. (As I always suspected)

All is good now and hopefully will remain this way 

My thanks to the “techies” who fixed the problem 😋