Showing results for 
Show  only  | Search instead for 
Did you mean: 

Surface Pro 4 not autodetecting and configuring Canon imageRUNNER ADVANCE C5035


Hey guys.  I'm an IT support guy for a small law firm 'round my area, and they've had this Canon imageRUNNER ADVANCE C5035 for a good while now.  It has, for the most part, been easy and good to set up and get working with every computer I've built for these folks, or which they've purchased.


Except one.


The head honcho just bought himself a brand new Microsoft Surface Pro 4 - you know, that device that Microsoft was gonna show those dirty OEMs what's what and embarrass them with?  Yeah, well, apparently the flagship Windows device just... doesn't pair with it.


I've tried with a desktop I was setting up right alongside - both running Windows 10 x64 - and I pointed it to the IP address and it autodetected it and autoconfigured it with absolutely no problem.  Took seconds, if that.


Okay.  Maybe it's a problem with wireless, I thought.


So I whipped out my Dell Venue 11 Pro (7130).  An older, thicker, certainly less sexy tablet as compared to the New and Improved™ Microsoft Surface Pro 4, right?  So I did the same thing.  It, too, running Windows 10 x64... and it, too, was set up and printing from that thing in under a minute.  Ooooookay.  I guess I know it's not a wireless issue.


Both my Dell Venue and his Microsoft Surface Pro are connected to the same LAN.  I didn't want to believe I would overlook something that simple, so yes, I checked.  Both connected to the same wireless network.  Both have this network under the "Private" network profile, and "File and Printer Sharing" is enabled on both for private networks.


Is there something I'm missing?  I even tried the Canon drivers straight from their website for this model, this is absurd.

Enter for a chance to win