Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

435 REPLIES 435

I have an Image Class MF4880dw that worked fine with Windows 7. Bought a new Asus laptop running Windows 10, downloaded the latest drivers from Canon. Printer works, but had the same scan issue as others, "Cannot communicate with the Scanner" message. 


What fixed my problem was as follows:

1) Right click on the desktop icon "Canon MF Toolbox 4.8

2) Click on "Properties"

3) Click on "Compatibility Tab"

4) Click on "Compatibility Trouble Shooter"

5) Windows will ask question if the application worked in older Windows versions. Then it will check and then have you run a scan test. The scanner worked, then Windows asked if I wanted to save the new settings. 


Worked for me and still working!

The key for me was unplugging and replugging the USB cable after removing driver file and restarting the computer.

1. Uninstall drivers and Toolbox Program (may need to boot in safe mode to uninstall toolbox)

2. Unplug USB Cable

3. Restart Computer

4. Download and Install Updated Drivers and Toolbox from Canon site

5. Replug USB

6. Open Toolbox and select Scan1


Firstly you need to download the latest Canon MF Toolbox from the Canon website. .

Once downloaded, install the application.

Once installed, right click on the application icon and select

Move to the compatibility tab and select the checkbox behind “Run this program in compatibility mode for”

From the drop-down list, select “Windows 7”

I am sorry but I am a completely hopeless ageing incompetent and need to have process of uninstalling drivers etc explained. Can the necessary steps be spelt out by some kind person please. The scanning problem is really infuriating as I need to scan for my work. And I keep on having to restart and try again - sometimes it works and sometimes it doesn't.

This worked for me and doesn't involve any removing of drivers or anything like that (I tried all other solutions in this thread, and this was the only one that worked and also the simplest--I have an MF8280Cw with Windows 10 x64)


On Printer:

1.Go to scanner and press the scan button

2.  Select "Remote Scanner"


On computer:

1. Goto bottom left of screen and click the windows logo

2. Type the word "scan"

3. click on the option that says "Scan Trusted Windows Store app"

4.Select correct "scanner" "source" and "filetype"

5. Press scan. 

6. It will save into "My Pictures" under a folder called scan

This works like a charm


Thank you.

Not a solution. Cannot scan from Toolbox 4.9.. Cannot scan from auto feeder into .pdf.

Sometimes an MF Toolbox or Windows 10 update will stop the scanner function. When that happens go to Control Panel and open System and on the left open Advanced Settings and then open Environmental Variables. Next go to the lower System Variables box and highlight Path. Next click New. Then find the current location of the Twain drivers under C:\Windows\ and enter the path to the Twain folder. The last folder should be the series of your printer. Mine was MF4100 for my MF4150. The problem is that the scanner can't find its drivers and this solves the problem.

The Cannon App didn't run under Windows 10 on our new Dell computers.  Using the Windows Fax and Scan app didn't find the scanner.  Turned out the problem was the Cannon has to be set differently.  We used to press SCAN, then choose From Computer.  That only works for computers that were set up by name on the Cannon.  Choosing REMOTE instead of Computer permits any computer on LAN to find it with any scanner app such as Windows 10 FAx and Scan and even the ancient PaintShopPro version 4.  


We we are using the driver downloaded from in January 2016.


Same thing worked for me.  Uninstall the toolbox and go to Control Panel\All Control Panel Items\Devices and Printers and remove all Canon devices.


Then install the drivers again and the toolbox again.


W10 upgrade or hooking up the device to a new W10 installation uses default windows drivers.  Reinstalling using Canon s/w did the trick.


I did have the "Windows Image Acquisition (WIA)" service set to this threads recommendations as well.


I didn't have to boot into Safe mode either.

click here to view the gallery