cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ImageClass MF733CDW unable to install scanner drivers

Baldy
Apprentice

Greetings!

I have an issue whereas I cannot install the scanner drviers, no matter what I & Canon Support have tried. 

Backstory:  Win10 finally updated to 22h2 (I kept putting it off since I was not having any issues) and since then I was unable to scan as there would be an error that the "computer is not found" when initiating from the printer, and scanner not found when trying to initiate from the computer (using scangear, etc.).   Prior to this, no issues.  I attempted to rollback the windows update, however this ended in having to run sfc /scannow and DSIM to make  windows boot.  Attempted to scan again to no avail.  Undid the rollback and went to the updated state. Still not able to scan.

This lead me down the rabbit hole of uninstalling the complete drivers (printer, scanner, fax), using the "Uninstal.exe" to remove remnants, delete ports, remove registry entries associated to the device, etc. with the help of 2 different tiers of Canon support for a total of probably over 4 hours...to no avail. Despite best efforts, the scanner drivers will simply not install.  To add a note, the internal wifi PCI card needs to be disabled on this hardwired PC to even attempt and Canon MF driver installation otherwise an error of "invalid IP address" pops up from the installer.  Installation attempts via USB fail as well on the scanner driver for some reason.  All of the troubleshooting has also been attempted using other user/admin accounts, as well as firewall off, defender, anti-virus off, etc. to no avail. 

I have read instances of other companies having the same issues with their multi-function devices, however most appear to have been resolved via updated drivers, patches, etc. 

The PC is connected via hardwire ethernet to a router.

The MF733Cdw connects to the router via WiFi. (Static IP set, IPV6 off, etc.)

Other Win10 devices connected via WiFi see the scanner and the scanner can send files to them. That being said, in the "printers & scanners" lists on the devices running on Win10 22h2 show "Canon MF733CDW UFR II" and a second device listing "MF731C/733C" with "Driver is unavailable" below that listing.

Printing is fine and unaffected since the updates.  Updated printer drivers install normally as well.

Anyone with a solution or insight that had a similar problem?

3 REPLIES 3

Baldy
Apprentice

Bump.  Still no solution.  Drivers appeared to install when I ran with the printer connected via USB, as they show under the drop downs in the windows printers section, but still unable to scan.  Also, still can't install the scanner drivers if I try disconnecting the USB and re-running just the scanner driver install. 

Thanks for being part of the conversation, Baldy!

This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, click HERE search our knowledge base or register your Canon gear HERE to access additional support options.

Thanks and have a great day!

Hi Danny,

That's the problem though.  I spoke with Canon support and then we did the remote desktop with the Canon technician to no avail.  A few days later a senior Canon support rep tried doing a deeper dive as well, but ultimately prefaced before we even did any troubleshooting that Canon is aware of this issue after the Windows 22h2 update (and subsequent updates) and does not have a resolution.  I was told to keep checking back on the support site to see if new drivers get released or a patch.  Given that I now have 2 computers with the same issue (and a laptop that will work, however windows shows errors with the driver in the Printers & Scanners panel), I'm sure I am likely not alone. At this point, I am merely hoping that someone was able to resolve this somehow, as uninstalling, reinstalling, deleting ports, manually removing registry entries, toggling other registry entries/settings, uninstalling/reinstalling updates, running sfc scannow & DSIM and all other windows tools does not solve the issue.

Avatar
click here to view the press release
Announcements