Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎06-11-2013
Accepted Solution

i have an EOS 24-105mm comms error

I have an EOS 24-105 attached to a 5D Mk III and get an error message: "Err 01 communications between the camera athd lens is faulty. Clean the lens contacts." This occurs when you attempt to shoot at any focal length except wide open. If you attempt to depress the shutter part way for trigger auto focus/exposure the lens motors seem to cycle continuously an fully depressing the button gives the error message on the back screen. placing it in manual focus on the lens and manual exposure on the left dial only stops the focus from searching but the motors keep cycling and the result is the same error message.

 

when this first occured i cleaned the contacts and resumed shooting normally. Over the course of several months it got worse then suddenly dramically worse to the state it is now in.

 

the lens is about 2 years old. what are my options for correcting this?

Esteemed Contributor
Posts: 2,388
Registered: ‎11-14-2012

Re: i have an EOS 24-105mm comms error

Sounds like a lens problem which will require servicing. About the only way to verify that is to try it on other bodies. I am assuming you have other lenses & that they work on your camera.

 

"A skill is developed through constant practice with a passion to improve, not bought."
New Contributor
Posts: 2
Registered: ‎06-11-2013

Re: i have an EOS 24-105mm comms error

Yes, tested with other lenes and spoke with canon support.

it's back to the factory.

was happy to hear they're claiming about a week turn around.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement