Showing results for 
Show  only  | Search instead for 
Did you mean: 

SOLVED Webcam utility WAS working, what has changed?


Windows 10, EOS 6D, EOS 100D both with latest firmware, Webcam utility 1.1, multiple cables, multiple ports, no "switch it off and on again" suggestions, please ... i have tried EVERY possible combination and resinstalled and restarted everything that can be! Yes, EOS utility is not running (I uninstalled it). Watched many YT videos, emptied google, nothing, but nothing works.

I installed the beta whenever it came out, connected first time to both cams. Since then I have been using them to make YT videos for my channel. I posted the last one on Jun 24th. Yesterday I came to make another and BANG - no webcam utility. The OBS Studio scene had EOS Webcam utility option greyed out. Creating a new one does not ever offer it as an option.


SOMETHING has change in those three days, and it wasn't anything I deliberately did. I suspect Windows10 has silently busted something in the background...(which would be a shocker, wouldn't it? 🙂 )

Points of note: in the working setup, before i powrred on the cam I saw the "EOS Webcam utility" screen. When I powered on the camera and selected movie mode, I got live view on the screen, and EOS window showed the same view./ All 100% as expected.
Today, I get totally black utility window and camera screen is black with the computer icon. I tried several other viewers, e.g. USB cam viewer app, zoom, iSpy they have the "local camera" option of EOS Webcam Utility, but when chosen, reply with can't open, or unvailable etc. NOTHING can view it. What has hold of it? 

During my experiments it seems like SOMETHING has already "grabbed" the camera. I suspect the MTP device. I dont recall ever seeing it before in device manager, nor having the cameras pop up in the explorer window, but...I may not have been looking that closely...

I NEED this to post my YT vids, it WAS working, what's changed ? Please help!!!

Phil Bowles 

Seems I forgot the ONE change I made - probably because it was the last thing I ever believed would cause the problem upgrading EWU from beta to 1.1. 


I found an archived download of beta 0.9.0, uninstalled 1.1; rebooted, installed beta 0.9.0 and  - hey presto - everything back the way it was...WORKING  


I think someone in the software development department needs to have a chat with the boys and girls who let 1.1 escape. You can hardly call it a "release" when it simply does not work! Beta 0.9.0 works 100% as expected on my pretty ordinary setup and 1.1 is absolutley, totally, 100% non-functional. As a long-time(46 years!) software developer myself, it's probably no surprise to hear I'm SERIOUSLY unimpressed, Canon.


Beta 0.9 worked pefectly - why did you change it? WHAT did you change? How well did you test it? (That last one is rhetorical). Because I understand how these things happen, I won't send you a bill for the 14 hours of my life I just wasted - but for goodness' sake, sort yourselves out!