cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

t4i Freezes

rajatxjain
Apprentice

Hi,

 

I bought my T4i with the 18-135mm STM lens about 6 weeks back from Amazon.  Almost every week since then I see my camera freezes a couple of times. NO matter what I do, it would not do ANYTHING. I tried turning mode dial, I tried clicking photos, I tried going to menu, I even tried to switch it off! And it won't work. The only way out is to remove the battery and put it back in.

 

There is no reliable way of reproducing the problem. I don't know what to do since it is so unreliable. I see that some other users have also seen this problem, but what is not conclusive is whether this is a firmware bug? Or is it that I just have a bad copy?

 

The firmware version as displayed in the camera is ver 1.0.1 and the lens version is 1.5.0.

 

Thanks,

 

Rajat

1 ACCEPTED SOLUTION

bobakman
Enthusiast

See this link for instructions on a new firmware update that should solve your issue.

 

http://usa.canon.com/cusa/support/consumer?pageKeyCode=prdAdvDetail&docId=0901e0248090cddd

 

 

"Cameras don't take pictures, photographers do."

View solution in original post

4 REPLIES 4

bobakman
Enthusiast

See this link for instructions on a new firmware update that should solve your issue.

 

http://usa.canon.com/cusa/support/consumer?pageKeyCode=prdAdvDetail&docId=0901e0248090cddd

 

 

"Cameras don't take pictures, photographers do."

Thanks a lot, I hope this solves my problem 🙂

 

Did it for 2 days and did not see an issue so far! I'll keep monitororing...

So I downloaded the update you suggested, but then what do I do.  How does that help the camera's functioning?

My camera works fine now after I followed teh instructions.

Avatar
click here to view the press release
Announcements