cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unusual Canon 5D Mk III firmware version 9.3.0 AB(34)

MikeSowsun
Authority
Authority

Is anyone familiar with this unusual firmware version on this Canon EOS 5D Mk III?

A member of a Facebook group has this firmware on his camera and I believe it is probably a “Factory Menu” firmware sometimes installed by Canon when they are servicing a camera. I don’t know if it is possible to revert to a normal firmware version. 

Can anyone here help?

https://hosting.photobucket.com/images/y17/msowsun/2661A859-393C-4CC2-A282-30BD9A1F5C5F.jpeg



Mike Sowsun
6 REPLIES 6

Peter
Authority
Authority

Factory menu. Probably not a different firmware and probably possible to close factory menu with Tornado, SPT or just visit a Canon service center.

ebiggs1
Legend
Legend

Well, Mike the question becomes, does the camera work as expected?  If it does and does what the owner wants, why bother? He can't install another version of the FW form the Canon web site?

EB
EOS 1DX and 1D Mk IV and less lenses then before!

The owner is saying the camera is not performing as expected (no High Speed Flash option) and they are unable to do a firmware upgrade. 

I am not confident they are knowledgeable enough to find the HSS menu, or do a proper firmware upgrade. All I know for sure is they have this strange firmware and I wonder if it prevents normal operations. 

Mike Sowsun

Wait isn't HSS set on the speedlite if its an older Canon speedlite. Older speedlites cannot be set using the speedlite control menu. The speedlite control menu does give you a choice to set HSS, Rear Curtain or 1st curtain sync. But you must use a 2008 or newer speedlite ie 430EX II, 580EX II or newer. 

-Demetrius

EF 16-35mm F/2.8L III USM, EF 24-70mm F/2.8L II USM, EF 28-135mm F/3.5-5.6 IS USM, EF 50 F/1.8 STM & EF 70-200mm F/2.8L IS III USM

EOS 40D & 5D Mark IV

430EX III-RT & 600EX II-RT


-Demetrius

Current Gear: EOS 5D Mark IV, EF F/2.8 Trinity, EF 50mm F/1.8 STM, EF 85mm F/1.8 USM, 470EX-AI & 600EX II-RT

Retired Gear: EOS 40D

amfoto1
Authority

That is odd.

The most current firmware for 5D Mark III that Canon shows is ver. 1.3.6.

I Googled and found reference to Capture One version 9.3.0 being needed for 5D IV, 5Ds and 5Ds-R. But that certainly shouldn't be installed in the camera. That was the only reference I could find to both a Canon 5D model and that version designation.

Maybe open a chat with Canon tech support?

***********


Alan Myers
San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7DII (x2), 7D(x2), EOS M5, some other cameras, various lenses & accessories
FLICKR

ebiggs1
Legend
Legend

Mike if it is a shop installed FW which I doubt there’s no way it would disable any feature.

EB
EOS 1DX and 1D Mk IV and less lenses then before!
Avatar
click here to view the press release
Announcements