cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel SL1-blank LCD screen

madhyastha
Apprentice

With LCD auto off enabled,LCD screen is blank  for quick control, doesnt show captured impages after taking picture and blank when changing mode using mode dial. I am owning this camera for more than a year.dont see any firmware update or reset button. I tried clear setting. No use so far.

5 REPLIES 5

TCampbell
Elite
Elite

With camera powered on... look at the back of the camera for a button labeled "Info".

 

That button toggles through several optional displays that can be offered on the LCD screen -- but one selection is to leave the LCD off.  Just press the "Info" button several times until it shows what you'd like to see (it cycles through 4 or 5 different choices.)

 

 

Tim Campbell
5D III, 5D IV, 60Da

geverson
Apprentice

I had a blank screen when I turned on my camera. All the other features worked I could bring up the menu and info.  In messing with the camera to correct it I now get the screen for whatever setting such as landscape, portrait, etc. when I turn on the camera but I cannot get the first information screen. I have adjusted the nose piece so that was the original problem.  But how do get it to start with my original information screen and view?

I don't know what you mean by "original information screen", but the info button will toggle amoung the screens. Also, the initial screen is somewhat context sensitive, you might have to change the mode.

My info button does not toggle through different screens, unless somehow I am doing it wrong. It gives me basic info or goes back to whatever selection I have made among landscape, portrait, M, AV, TV, P, etc.  What I mean by first screen is that when I turn on the camera It gives basic info like battery life, how many photos remain, etc. I no lnger get this page and it also does not automatically bring up a picture for review after it is taken.


@geverson wrote:

My info button does not toggle through different screens, unless somehow I am doing it wrong. It gives me basic info or goes back to whatever selection I have made among landscape, portrait, M, AV, TV, P, etc.  What I mean by first screen is that when I turn on the camera It gives basic info like battery life, how many photos remain, etc. I no lnger get this page and it also does not automatically bring up a picture for review after it is taken.


I have not used a Rebel “SL”, but all of the Rebels share common features and behavior.  

 

What info displays appear should be fully configurable in the menu system.  What screen appears on power up, if any, also should be configurable in the menus.

--------------------------------------------------------
"The right mouse button is your friend."
Avatar
click here to view the gallery
Announcements