Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5 Freezing up After Firmware 1.5 Update...


I've heard this is an issue, and I experienced it yesterday while shooting some birds. My R5 locked up about 5 times in a row during one session. Each time I took the battery out and it froze repeatedly. Eventually it stopped, but I was not too pleased. Are others having this issue, is canon going to fix it, and is there a way to go back to version 1.4 as an interim solution?



I have had similar problems with an R5 with battery extender while using my 100-500mm ever since I upgraded to firmware 1.5. I am using AI Servo at the time with '*' Set to Eye focus and 'AF ON' set to focus. This problem happens consistently when I am watching a bird for a while and take my finger off the eye focus back button "*" on my camera. I consistently get a crash when the bird starts to move, I press the eye focus. The key is a pause of at least 5 minutes. One work around is the hit the AF On button (Set to focus) first. At one point I made the AF On button my eye focus button, same result. I have tried all the above suggestions with no luck at all. The issue does NOT happen when using any other lens. I had a friend out with me yesterday who had similar problems and then they stopped when he changed his crop factor on the red menu 1. Now no more issues. Try it, since you are probably shooting birds the crop helps. Canon Needs to fix the firmware.

View solution in original post



I recommend that you contact Canon Support at your earliest convenience.  

"The right mouse button is your friend."


I'm sorry to hear this. I just updated my R5 to firmware 1.5 yesterday, but I haven't yet been out shooting to really test things out.

If you wish, you can download and install the previous version, just as you did this new version. Go to Canon's site, then under Support, Drivers and Downloads, select Firmware, and you'll see that you can download any of the earlier versions for installation. (At least this is how it is on their US site). Follow the update procedure listed within the downloaded 'zip' file and you should be all set.



EOS R5, 24-105 f4L, 15-35 f2.8L, 100 f2.8L, EF-RF Control Ring converter, 600EX-RT
EOS 5DIII, 24-105 f4L, 100-400 f/4.5-5.6L IS II, 70-200 f4L



EOS R5, RF24-105 f4L IS, RF15-35 f2.8L IS, RF100 f2.8L IS, EF-RF Control Ring converter
EOS 5DMkIII, EF24-105 f4L IS, EF100-400 f/4.5-5.6L IS II, EF70-200 f4L IS, GP-E2, 500D Close-up lens 72mm, 600EX-RT

The R5 doesn't allow downgrading the firmware.


my r5 froze 10x today... appr. every minute!!

with native R 85mm lens, it worked without problems before the new update.

Have you figured out a fix?


I am having this problem too.  It hangs up.  I turn it off and it remains on.  I have to remove the battery to resolve it.  Not pleased at all.  I will contact Canon support directly when I get the time.  This mirrorless update thing is a blessing and a curse.  Never had an issue with my 5div.  


I have had my R5 (with v1.5 firmware) with RF100-500 lens lock up about half a dozen times during shooting on multiple days. The only work around has been to remove the battery and reinsert. It never happened with the older versions of firmware. In all the instances, it was the original Canon battery that came with the camera.

Thanks & regards,


My R5 has problem with v1.5 firmware, and locking up any time when I take several photos. It freezes up and only solution for that is that i have to take out battery and put them back in. I never had this problem with v1.4 firmware. Is there any real fix for this problem because i read about it and it is a common one after latest firmware update? I should mention that this problem is not tied with any lens or memory card because i tested it.  

Thanks in advance. 


It certainly seems that there is some sort of issue with the firmware update. Mine only has frozen up that one sequence, but it was the first time for me. Others are also having issues. I hope canon is looking at this and are thinking about solutions. So far the only solution I've heard is to go back to 1.4.