cancel
Showing results for 
Search instead for 
Did you mean: 

LCD won't work on Manual settings

LightTrap
Apprentice

I have a Canon Eos Rebel T5 and can't do without my manual settings.  If I switch the dial to Auto, Creative Auto, Macro, or any of the preset categories, the LCD displays just fine and the camera takes pictures as usual.  However, if I move the dial to Manual or Aperture Priority, Shutter Priority or any of those settings, the LCD goes blank.  When I hook it to the computer and use the EOS Utility, I can control the settings and it works fine.  Is there anything I'm missing here?  I have some insurance plan I bought, and this camera did this once before.  I was in the rain but the camera didn't get that wet, I was keeping it pretty dry most of the time.  Any suggestions?

2 REPLIES 2

Waddizzle
Legend

The camera has "Basic" and "Creatibe" modes.  The Creative Modes are P, Av, Tv, and M.  Press the "Q" button to see the camera settings when using the creative modes.  The camera is saving power but not turning on the LCD every time you change modes.

 

There should also be a setting in the menu that enables and disables screen tips, too.  As a last resort, find the menu setting that resets the camera back to factory defaults.  Warning, resetting the camera clears out any custom settings you may have set.

--------------------------------------------------------
"The right mouse button is your friend."

diverhank
Authority

When in doubt, reset the camera to default settings.  It is most likely that the LCD off/on option has been inadvertently set. You can find it on page 193 of your manual.  While setting the camera to one of the "non creative" modes (Av, Tv or M), set the LCD monitor option to either the first or 3rd option and not the second one.

 

Capture.JPG

================================================
Diverhank's photos on Flickr
Announcements