Showing results for 
Show  only  | Search instead for 
Did you mean: 

LCD screen has gone blank


I received the Rebel t4i for Christmas. It's been working great until today. The lcd screen no longer shows any information. If I press any of the setting buttons (ISO, etc), nothing shows up. It worked fine this past weekend.


I understand your desperation. It caused me to go back and double-check my previous statements, based on a discovery long ago. My camera is an early SL1. It does have a small (4x7 mm) rectangular switch centered between the rubber part of the eyecup and the hot shoe. I did not find it documented anywhere and have no idea of its function(s). It might relate to a 90 degree viewer attachment which I know nothing of. I know you have a different camera. In desperation, maybe yours somewhere has a switch related to whatever the function on mine is.  


I had this problem too. If the Canon eyecup (the rubber peice that slides on and off the viewfinder) slides up a little bit, the screen will not work. Just push the eyecup down and into place and the screen will function again

Thanks for your suggestion of cycling through the Info button. That fixed my problem with the LCD being black while trying to use the camera for taking pictures (it worked fine when using the Menu and when viewing pictures on the SD card). I had heard that the display going black was an expensive problem owners of the 70D (which is the camera I have that had the problem) have been experiencing, and I wasn't looking forward to that! Luckily, I tried this one last possibility, and it worked! Thank you again!
click here to view the press release